Information:

Environment

  • Dynatrace Classic Portal – One View > Diagnotics > Instant test
  • Backbone Transaction
  • Last Mile
  • Mobile

 

Symptoms

  1. Missing Instant Test options for Last Mile and Mobile.
  2. Fewer folders listed under Instant test list than under Performance Tests > Diagnostics.
  3. Cannot find Instant test option on One View.

 

Solution

Instant test feature is designed for active tests only. If there is not any active tests under a test folder or for certain type of tests, the related option will not be displayed under Instant Test. It is not a configuration problem and just how the feature designed to be. Once you activate a test, it will be displayed.

1. Instant test options:

  • If there are no active tests for Backbone, Last Mile and/or Mobile, the options are invisible.


2. Folder and Tests:

  • If there are no active tests under a certain folder, the folder will not be visible in the Instant Tests list
  • If some tests are inactive, you will not see them under the choose test chart.


3. The whole Diagnostics:

  • If there are no active tests at all for Backbone, Last Mile, Private Last Mile or Mobile, you will not see any option and the Diagnostics will display a note:
    "You currently have no active tests in your account. Please visit My Settings to add tests."
  • Go to Admin > My Settings and activate or add a test. You will see the options displayed again.

 

Root Cause

Instant test feature is designed for active tests only.