Icon

Comments have been closed on this page. Please use AppMon & UEM Plugins forum for questions about this plugin.

Overview

This monitor collects health and performance information from the Endeca dgraph server.

Plugin Details

Plug-In Versions

EndecaMonitoringPlugin_1.0.4.zip

dynaTrace Versions

>= 5.5

Author

v1.0.1, v1.0.2: Kevin Jackson (Dynatrace)

v1.0.3: Ingo Hackl (Dynatrace)

v1.0.4: Sean McConville

License

dynaTrace BSD

Support

Not Supported

Known Problems

 

Release History

2013-06-12 - Initial Release

2014-10-08 - 1.0.1 Release to change most "info" logging to "fine" to help reduce the log file size, and to test with dT v6.0.

2015-03-26 - 1.0.2 Release that fixes previous issue with "fine" logging, and tested with new versions of Endeca and dT v6.1.

Provided Measures

  • CPU USAGE
  • HOST REACHABLE
  • NUMBER OF REQUESTS
  • AVERAGE QUERY PERFORMANCE
  • MAX QUERY PERFORMANCE
  • AVERAGE REQUEST TIME
  • MAX REQUEST TIME
  • TIME SINCE LAST INDEX UPDATE

Configuration

This monitor uses a HTTP GET request to pull back measures from the Endeca dgraph server. The plugin is executed remotely from the dynaTrace collector(s).

NOTE: This plugin has been tested with dT versions 5.0-6.1 of dynatrace.
NOTE: This plugin was tested against Endeca version 6.2.1.583084, but has been proven to work with newer versions.  Even though the dgraph web page now has various tabs to navigate through, they still use the same XML template file.

Contribution

Feel free to contribute any changes on Github

  1. Anonymous (login to see details)

    Hi,

    Thanks for the plugin Kevin. Sounds interesting.

    I am thinking about using it at a customer who has Endeca tiers. What is the impact of this monitor? Can it run on the same monitoring collector with a few other URL monitors?

    Best regards,

    Dennis

     

  2. Anonymous (login to see details)

    Dennis-

    Apologies for the delayed reply. Yes, it can run on a collector with other URL monitors.  The plugin simply makes a GET request to the Endeca status page of each host/port combination, retrieves the XML response and parses out the specified measures.  

    Thanks,

    Kevin

  3. Anonymous (login to see details)

    Thanks, Kevin. Customer currently has problems to provide me the URL for the dgraph server which pulls the data via the GET. Hope I can see some Endeca data soon.

  4. Anonymous (login to see details)

    Hi Kevin,

    First off, thanks so much for creating this plugin.

    We're very much looking forward to trying this in our QA DynaTrace server and then in the Prod server if possible.

    The plugin only seems to be have the port and path values as configurable. We're not sure how to connect to a particular host where the MDEX server is running.

    If you could add some configuration steps to this thread, we would greatly appreciate it.

    Thanks in advance.

     

  5. Anonymous (login to see details)

    Pavan-

    I'm very sorry for the delay in responding to your question.  I hope that you have resolved your issue, but in case you have not, let me try and answer your question.  The inputs for the plugin are as you pointed out, but in the table below those inputs is where you specify which hosts you want the plugin to execute to.  Use the "+" button on the right to create an entry for each of your Endeca hosts.  You should be able to use a single plugin instance for multiple servers that use the same port.  

    Please let me know if you were able to figure this out, or if you have other questions about the plugin.  

    Thanks,

    Kevin

  6. Anonymous (login to see details)

    Dear Kevin,

    I tried to retireve endeca information using the plugin, however I encounter some issues. In the monitor task the error is stating the following reason for failure "Error during execution of plug in occurred" and error message "Executing monitor failed".

    The Plugin log does not say much it states

    2015-12-14 09:37:30 WARNING [EndecaMonitor@New Endeca Monitor_0] Previous message was repeated 1 times.

    2015-12-14 09:37:30 WARNING [EndecaMonitor@New Endeca Monitor_0] warning

    2015-12-14 09:37:30 INFO [EndecaMonitor@New Endeca Monitor_0] Executing method: , URI: http://xyz:9604/admin?op=stats

    2015-12-14 09:37:30 INFO [EndecaMonitor@New Endeca Monitor_0] Parrsing XML from: http://xyz:9604/admin?op=stats

    2015-12-14 09:37:33 INFO [EndecaMonitor@New Endeca Monitor_0] Retrieving XML Results...

    2015-12-14 09:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] info

    2015-12-14 09:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] Executing method: , URI: http://xyz:9604/admin?op=stats

    2015-12-14 09:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] Parrsing XML from: http://xyz:9604/admin?op=stats

    2015-12-14 09:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] Retrieving XML Results...

    2015-12-14 09:57:30 INFO [EndecaMonitor@New Endeca Monitor_0] info

    2015-12-14 09:57:30 WARNING [EndecaMonitor@New Endeca Monitor_0] Previous message was repeated 1 times.

    2015-12-14 09:57:30 WARNING [EndecaMonitor@New Endeca Monitor_0] warning

    When I tried manually open the url I get the Endeca MDEX Engine (dgraph) Server Statistics returned. I noticed though that the version of Endeca is "Endeca Information Access Platform version 6.1.4.530518, 6.1.4.530518"

    Could the version of  Endace be an issue, I noticed you tested with a newer version of Endeca.

    Kind reagrds,

    Mark

  7. Anonymous (login to see details)

    It seems that the error occurs when it gets to the Query section. This will result in a nan value, apparently the plugin can not handle the nan value returnede. See the Fine log details I collected.

    2015-12-14 10:37:30 INFO [EndecaMonitor@New Endeca Monitor_0] Executing method: , URI: http://xyz:9604/admin?op=stats
    2015-12-14 10:37:30 INFO [EndecaMonitor@New Endeca Monitor_0] Parrsing XML from: http://xyz:9604/admin?op=stats
    2015-12-14 10:37:30 INFO [EndecaMonitor@New Endeca Monitor_0] Retrieving XML Results...
    2015-12-14 10:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] info
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] fine
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] Plugin Starting Up Now...
    2015-12-14 10:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] Executing method: , URI: http://xyz:9604/admin?op=stats
    2015-12-14 10:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] Parrsing XML from: http://xyz:9604/admin?op=stats
    2015-12-14 10:47:30 INFO [EndecaMonitor@New Endeca Monitor_0] Retrieving XML Results...
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The element tag is set to: data_information
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The XML attribute is equal to: data_date:
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The xml attribute measure value is equal to: Sun Dec 13 19:45:02 2015
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The element tag is set to: requests_information
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The XML attribute is equal to: num_requests:
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The xml attribute measure value is equal to: 168
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The element tag is set to: rusage
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The XML attribute is equal to: user_time_seconds:
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The xml attribute measure value is equal to: 17.23 seconds
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The element tag is set to: stat
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The XML attribute is equal to: name:HTTP: Total request time
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The xml attribute measure value is equal to: 54.2361
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The element tag is set to: stat
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The XML attribute is equal to: name:HTTP: Total request time
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The xml attribute measure value is equal to: 54.2361
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The element tag is set to: stat
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The XML attribute is equal to: name:Query
    2015-12-14 10:47:30 FINE [EndecaMonitor@New Endeca Monitor_0] The xml attribute measure value is equal to: nan


    Kind regards,

    Mark

    1. Anonymous (login to see details)

      Hi Kevin Jackson,

      My monitor is failing with the same error. The plugin was working fine until yesterday and randomly started failing yesterday. It started working again yesterday and it is failing now again. I am able to successfully run the below command from the collector machine. That means there is no issue with connecting to Endeca from collector. Please let me know why the monitor fails randomly sometimes and how to fix it?

      curl -X GET http://xyz:15000/admin?op=stats

      Thanks,

      Keerti

  8. Anonymous (login to see details)

    Dear Kevin,

    I am not a developer therefore I hope you can provide a changed plugin that considers the return of the Query as nan. I have for the customer a quick fix, by changing your code where it retireves the value of the query and set it to fixed value 0.

    Changed it to:

                //retrieve measure for Endeca Avg Query Performance

                this.queryPerfAvg = 0;

                //Double.parseDouble(retrieveXmlElementTags(STAT, STAT_ATTR_NAME, STAT_ATTR_AVG, STAT_QUERY_PERF_NAME));

                //retrieve measure for Endeca Max Query Performance

                this.queryPerfMax = 0;

                //Double.parseDouble(retrieveXmlElementTags(STAT, STAT_ATTR_NAME, STAT_ATTR_MAX, STAT_QUERY_PERF_NAME));

    Can you change the plugin in a way that it can handle nan values returned?

    Kind regards,

    Mark

  9. Anonymous (login to see details)

    Hi folks,

    I've tried to use the plugin but I am geting "binaries missing" result status...

    Any help?

  10. Anonymous (login to see details)

    Lucas-

    Did you see Dave's post in the general forum about his ability to download and run the plugin, and question about looking at the Endeca plugin log created by the collector?  If not, please look for the log file and post back what you find.  Thanks!

    Kevin

  11. Anonymous (login to see details)

    Hi,

    I have implemented the plugin in our Perf environment and seems to be working well.  I occasionally get the log messages below in Red.

    Number of Requests looks to be cumulative since server start.  It would be much better to be either Reqs/Sec or Requests in the interval (delta). 

    I guess CPU usage is the same, cumulative since server start.  Util or seconds in the interval would be better.

    Is it possible for the plugin to be modified as described?

    Thanks

    Dan

     

    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _0] info
    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _0] Executing method: , URI: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _0] Parrsing XML from: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _1] Executing method: , URI: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _1] Parrsing XML from: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _1] Retrieving XML Results...
    2016-07-28 11:19:40 INFO [EndecaMonitor@Endeca Perf _0] Retrieving XML Results...
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _0] info
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _1] info
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _0] Executing method: , URI: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _1] Executing method: , URI: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _1] Parrsing XML from: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _0] Parrsing XML from: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _1] Retrieving XML Results...
    2016-07-28 11:24:40 INFO [EndecaMonitor@Endeca Perf _0] Retrieving XML Results...
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _0] info
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _0] Executing method: , URI: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _0] Parrsing XML from: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _1] info
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _1] Executing method: , URI: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _1] Parrsing XML from: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _0] Retrieving XML Results...
    2016-07-28 11:29:40 INFO [EndecaMonitor@Endeca Perf _1] Retrieving XML Results...
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _1] info
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _0] info
    2016-07-28 11:34:40 WARNING [EndecaMonitor@Endeca Perf _1] Previous message was repeated 3 times.
    2016-07-28 11:34:40 WARNING [EndecaMonitor@Endeca Perf _1] warning
    2016-07-28 11:34:40 WARNING [EndecaMonitor@Endeca Perf _0] Previous message was repeated 3 times.
    2016-07-28 11:34:40 WARNING [EndecaMonitor@Endeca Perf _0] warning
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _1] Executing method: , URI: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _0] Executing method: , URI: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _1] Parrsing XML from: http://lnxtst0121:14000/admin?op=stats
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _0] Parrsing XML from: http://lnxtst0120:14000/admin?op=stats
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _1] Retrieving XML Results...
    2016-07-28 11:34:40 INFO [EndecaMonitor@Endeca Perf _0] Retrieving XML Results...

     

     

  12. Anonymous (login to see details)

    Hi Kevin Jackson,

    My Endeca monitor is failing with the below error in the collector logs everytime Endeca is restarted. I am not sure why this is happening.

    2016-08-20 19:11:25 WARNING [UserPluginManager] java.lang.NumberFormatException - For input string: "nan"
    java.lang.NumberFormatException: For input string: "nan"
    at sun.misc.FloatingDecimal.readJavaFormatString(FloatingDecimal.java:1250)
    at java.lang.Double.parseDouble(Double.java:540)
    at com.dynatrace.diagnostics.plugin.endecamonitor.EndecaMonitor.execute(EndecaMonitor.java:185)
    at com.dynatrace.diagnostics.sdk.UserPluginManager.a(SourceFile:757)
    at com.dynatrace.diagnostics.sdk.UserPluginManager.b(SourceFile:490)
    at com.dynatrace.diagnostics.sdk.UserPluginManager.executePlugin(SourceFile:285)
    at com.dynatrace.diagnostics.sdk.MonitorPluginExecutor.execute(SourceFile:51)
    at com.dynatrace.diagnostics.sdk.MonitorPluginExecutor.execute(SourceFile:26)
    at com.dynatrace.diagnostics.scheduling.impl.ServerJobCenterRegistry.a(SourceFile:190)
    at com.dynatrace.diagnostics.scheduling.impl.ServerJobCenterRegistry.a(SourceFile:413)
    at com.dynatrace.diagnostics.scheduling.impl.ServerJobCenterRegistry.execute(SourceFile:337)
    at com.dynatrace.diagnostics.scheduling.impl.SchedulerJob.a(SourceFile:101)
    at com.dynatrace.diagnostics.scheduling.impl.SchedulerJob.work(SourceFile:92)
    at com.dynatrace.diagnostics.scheduling.impl.SchedulerJob.executeJobInfo(SourceFile:241)
    at com.dynatrace.diagnostics.scheduling.impl.QuartzJob.execute(SourceFile:45)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
    at com.dynatrace.diagnostics.scheduling.impl.QuartzThreadPool$WorkerThread.run(SourceFile:788)

    I am able to successfully run the below CURL command from the collector machine. That means there is no issue connecting to Endeca from collector. Please let me know why the monitor fails when Endeca is restarted and how to fix it?

    curl -X GET http://xyz:15000/admin?op=stats

    Thanks,

    Keerti

  13. Anonymous (login to see details)

    Hi,

    I'm working with Keerti on this problem.

    I would like to load the plugin into my Eclipse environment and do some debugging myself.  However, it seems the .jar file is missing the development related folders and files.  

    Can you post the complete package so we can debug this ourselves?

    Thanks,

    Bill Rodgers

    1. Anonymous (login to see details)

      Hi Bill,

      the source files and libraries are contained in the jar-file. Which files are you missing?

      Ingo

  14. Anonymous (login to see details)

    Hi Ingo,

    The problem seemed to be that Eclipse couldn't find a project in the unpacked jar file.  I looked at another project that does load correctly, found that the working project contained folders bin, build, and res plus a .project file.  I created the folders, copied and modified the .project file from another project and it all worked fine.  I suspect the .project file is the most important part.

    The error we found was in about lines 357 and 385 where valueX != "nan" should have been !valueX.equals("nan").  That fixed the problem mentioned several times on this thread.  I haven't had time to post the whole new .jar file.

    Bill

    1. Anonymous (login to see details)

      Hi Bill,

      thanks a lot for figuring this out.

      Can you please commit the changes and the .project file to the GitHub repo?

      Thanks

      Ingo

       

    2. Anonymous (login to see details)

      Hi Bill,

      you could also sent the .project file to community@dynatrace.com and I will push it to GitHub.

      Thanks

      Ingo

       

       

      1. Anonymous (login to see details)

        Have emailed file.

        Bill

  15. Anonymous (login to see details)

  16. Anonymous (login to see details)

    Ingo Hackl Will you post to GitHub as well as updating the version of the Monitor on the downloads? I'm running into the same exact issue regarding the "nan" issue. I was collecting good data for about 5 days since installation until it failed. 

    Thanks 

    Bob Crumley

    1. Anonymous (login to see details)

      Hi Bob,

      I have fixed the "nan" issue and provided a new version of the plugin: https://github.com/Dynatrace/Dynatrace-Endeca-Monitoring-Plugin/releases/tag/v1.0.3

      Could not test it with Endeca but I hope everything works.

      Ingo

       

      1. Anonymous (login to see details)

        Ingo -

         

        Thank you very much! I applied it in the testing enviornment and it upgraded instantly, and as soon as I ran the monitor it came back green. Now instead of crashing I'm seeing 

        SEVERE [EndecaMonitor@Endeca_0] The value of Query(nan) is null or nan, so a 0.0 value was returned:
        INFO [EndecaMonitor@Endeca_2] Retrieving XML Results...
        SEVERE [EndecaMonitor@Endeca_2] The value of Query(nan) is null or nan, so a 0.0 value was returned:

         

        I'm not seeing this for my Endeca_1 monitor, so now I have something to bring back to my team. Thanks so much for the quick update, v1.03 seems to work.

         

        Bob

      2. Anonymous (login to see details)

        Hi Ingo Hackl,

        I have upgraded Endeca monitor to v1.0.3 but now Properties button is disabled for me. Then I opened system profile --> Monitors and clicked on Create button. Endeca monitor is not available in the given Monitor Type list. Is this not compatible with DT version 6.1.

        Thanks

        1. Anonymous (login to see details)

          Hi Sankhar Rao Pedada

          I just tried with 6.1 and I have the properties button enabled but "Endeca Monitor" does not show up in the Monitor Type list.

          I will need to look into this.

          Ingo

           

          1. Anonymous (login to see details)

  17. Anonymous (login to see details)

    Hello,

    v1.0.2 gave me this error: SEVERE [EndecaMonitor@Endeca_0] The value of Query(nan) is null or nan, so a 0.0 value was returned
    and also threw NPE's when connection exceptions occurred. 

    The version linked above (v1.0.3) would not let me run the monitor (Even in 6.2).

    I have created a custom fork of this that is currently working ok in our environment. If anyone else was facing the same issues as me:
    https://github.com/smc87/dynaTrace-Endeca-Plugin/releases/tag/v1.0.4

     

    1. Anonymous (login to see details)

      Hi Sean,

      can you please merge your changes back into the original repository (https://github.com/Dynatrace/Dynatrace-Endeca-Monitoring-Plugin) ?

      Thanks

      Ingo

       

       

      1. Anonymous (login to see details)

        I was about to do this but it looks like you had already updated the nan value stuff.

        Also I opened the latest jar file and started work from there so I'm not sure if the github page was ever upto date with the latest jar?

         

        Apart from the change to NaN parsing that you have already made the only other correction i made was to the NPEs that were thrown in a failed connection attempt. 

        http://imgur.com/a/zBEkm

         

         

        I've submitted a PR with corrections to the issue (actually fixed in another location that i hadn't spotted)

  18. Anonymous (login to see details)

    Yea Sean

    Facing same issue with v1.0.3. I have upgraded Endeca monitor to v1.0.3 but now Properties button is disabled for me. Then I opened system profile --> Monitors and clicked on Create button. Endeca monitor is not available in the given Monitor Type list.

    Can you please also look into following and provide your suggestion what's wrong there because still I'm not able to get values for all measures except HostReachable.

    https://answers.dynatrace.com/questions/158571/endeca-monitor-102-not-capture-values-for-measures.html?_ga=1.93423582.2129408363.1469551572

    1. Anonymous (login to see details)

      did you try the v1.0.4 version?

      1. Anonymous (login to see details)

        Not yet...I will try this also and will get back to you if there is some update on this...Thanks

        1. Anonymous (login to see details)

          I tried with v1.0.4 but getting same issue. Following I found in log files:

          2016-09-26 15:42:33 FINE [EndecaMonitor@Endeca Monitor_0] Plugin Starting Up Now...
          2016-09-26 15:42:33 INFO [EndecaMonitor@Endeca Monitor_0] Executing method: , URI: http://abc.xyz.org:12345/admin?op=stats
          2016-09-26 15:42:33 INFO [EndecaMonitor@Endeca Monitor_0] Parrsing XML from: http://abc.xyz.org:12345/admin?op=stats
          2016-09-26 15:42:54 SEVERE [EndecaMonitor@Endeca Monitor_0] Previous message was repeated 1 times.
          2016-09-26 15:42:54 SEVERE [EndecaMonitor@Endeca Monitor_0] Connection Exception Thrown:java.net.ConnectException: Connection timed out: connect
          2016-09-26 15:42:54 FINE [EndecaMonitor@Endeca Monitor_0] Plugin Status: URL: http://abc.xyz.org:12345/admin?op=stats
          Connection timed out: connect

          and then immediately I browsed the URL http://abc.xyz.org:12345/admin?op=stats and I was able to get the stats. Couldn't find out where should check now.

          Any suggestion.

          Thanks

           

          1. Anonymous (login to see details)

            Hi when you tested the url, did you test from the collector that is running the monitor? This server must also have access. 

            (and without any proxy)

            1. Anonymous (login to see details)

              Sean,

              Finally I'm able to get the measures values from monitor actually I changed the collector in monitor where plugin was executed. Now here are two things

              1. I want to create a dashboard for this monitor so do you have any reference sample or suggestion how can we use available measures to create a chart.

              2. Does following configuration is correct or any further correction is needed for best result

              • Monitor is scheduled to run for Every 1 minute
              • In incidents Evaluation timeframe is 10 s
              • Measures threshold is severe
              • Measures aggregation is avg

              Thanks

               

              1. Anonymous (login to see details)

                Hi Sankhar - Glad you got it working! 
                For my dashboard, I just created 6 charts, each showing one different part. When there were 2 measures for max v average, I just added both to one chart. The client who needs this is happy with the result.

                 

                As for the configuration, as long as you get data it's up to you. I usually have monitors run every minute and thus evaluation timeframe is 2 minutes. All is up to you though. The more it runs the more the servers are touched, but the more granular and accurate the measures.

                1. Anonymous (login to see details)

                  Hi Bobby,
                  Thanks for quick reply...I did the same configuration and set an alert in incidents for email notification if HostReachable values goes below 0.0 within 5 minutes timeframe. Actually for me 2 minutes evaluation timeframe is not available I don't know how it's coming in your dynatrace client.

                  Now in chart for time being I have created individual chart for each measures but didn't understand CpuUsage measure. In chart Y- axis it shows values in seconds but what does it means.

                  Similarly can you please explain little bit about QueryPerformanceAvg/Max and RequestTimeAvg/Max.

                  Thanks

                   

                  1. Anonymous (login to see details)

                    Unfortuneately, I'm not very aware of each of these metrics. I know they are useful for those that deal with Endeca as they are the measures from the admin page. You'll have to speak with someone more experienced with the actual system rather than just setting up the monitoring.

                    1. Anonymous (login to see details)

                      Ok got it...but can you tell me how did you set evaluation timeframe to 2 minutes...
                      For me following are the values which is available in evaluation timeframe drop-down list
                      10s
                      1 min
                      5 min
                      10 min
                      15 min

                       

                      1. Anonymous (login to see details)

                        Sankhar - Apologies, I have 5 minutes not 2 minutes. My mistake.

                        1. Anonymous (login to see details)

                          Oh no problem....Anyway thanks for your help

                        2. Anonymous (login to see details)

                          Bobby,
                          Do you have any idea on URL Monitor. I have set up for website but getting following error message in Detailed message:

                          SSL handshake failed, this may be caused by an incorrect certificate. Check 'Disable certificate validation' to override this.

                          Exception message: peer not authenticated
                          Does Disable certificate validation check-box un-check is the only solution

                          1. Anonymous (login to see details)

                            Sankhar - Please post this question in "Answers" and keep this forum about the Endeca monitor. They'll be abel to assist you in the general Q/A forum.

                            1. Anonymous (login to see details)

                              Oh ok thanks...I will do that...