Icon

Comments have been closed on this page. Please use AppMon & UEM Plugins forum for questions about this plugin.

Overview

This plugin enables dynaTrace Dashboard Reports to produce JSON Output. Use this Plugin to integrate Dynatrace Dashboard data with e.g: your existing Web 2.0 Portals by requesting Dynatrace report-data in JSON data format.

Name

JSON Reporting Plugin

Version

6.5.0.1000

dynaTrace Versions

>= 6.5

Author

Dominik Stadler (dominik.stadler@dynatrace.com)

Support

Not Supported

Download

com.dynatrace.diagnostics.report.json.plugin.dtp

for Dynatrace AppMon before 6.5 use this version

SourcesGithub

Description

This Plugin provides a new reporting type for both Client and Server-Side Reporting.

In the Client you have a new JSON Format Option

Through the Server-Side Reporting Interfaces it provides different JSON Formatting options with JSON from XML providing a pretty printed version of the data that you would normally get using the XML Format Type.

Format Option through the Server-Side Reporting Interface

Following shows the JSON from XML Output

Installation

1. Download the plugin
2. Either double click the .dtp file or Import the Plugin through Manage Plugins
3. After installing the Plugin you have to restart both Dynatrace Server and Client

  1. Anonymous (login to see details)

    Hello -

    I am trying to implement this at a customer site, but when I try to view the data in my browser as an JSON from XML format, I get a 500 error.  Any quick ideas for anything that I might be doing wrong?

    Thx,

    JB

    1. Anonymous (login to see details)

      Seems something goes wrong on the server, can you fetch the server-log via the "System Information" Dashlet (Available under "Help"), it should contain some information about what happened.

      Also which version of Dynatrace are you using?

      Dominik.

  2. Anonymous (login to see details)

    Hey Dominik,

    It looks like there may be a conflict with Dynatrace 6.3.  After adding the plugin, the report option does not show up:

    Has the plugin been tested with Dynatrace 6.3?

    Thanks,

    Josh

  3. Anonymous (login to see details)

    Hi,

    It seems there were some changes to this that make the plugin not show up in the Client. As a workaround you can enable "debug-mode" via CTRL-SHIFT-F9 (while no dialog is shown) to make them show up in the Reporting-dialogs until we sort this out either with a newer plugin-version or a fix for the Client.

    Dominik.

  4. Anonymous (login to see details)

    I have now updated the plugin to a version that should be supported by Dynatrace 6.3 as well.

  5. Anonymous (login to see details)

    Wow, thanks for the quick turnaround Dominik!  Will test the plugin today and let you know if I encounter any issues.

  6. Anonymous (login to see details)

    Hi Dominik,

    It doesn't seem to work for appmon 6.5. Same issue as described above for 6.3. I have added the plugin (build from source) but the JSON File Type does not appear. Not in the client and not via the web interface.

    Even in debug mode, it doesn't show.
    And I don't see any related messages in the server.log.

    I guess 6.5 introduced some braking changes. Any help is greatly appreciated because I would love to use this plugin.

    Thanks,

    Bert

     

    1. Anonymous (login to see details)

      I had to restart server and client to make the plugin show up, but then it failed with some internal error, thus I had to release a new version with some changes which is available above now.

      1. Anonymous (login to see details)

        Great, many thanks. It works very well now.

  7. Anonymous (login to see details)

    Is this plugin compatible with AppMon v7?

    1. Anonymous (login to see details)

      I did a quick check and it seems the version 6.5.0.1000 works fine with 7.0 as well. Please comment here or create an issue if you run into problems.