Icon

Comments have been closed on this page. Please use AppMon & UEM Open Q & A forum for questions about this plugin.

Overview

 

Slack integration for Dynatrace. This plugin will post incidents to a channel you have defined through a Slack WebHook.

Name and Version

SlackChat 0.10.0

Compatible with

Dynatrace 6.3

Author

Tarjei Utnes

License

Dynatrace BSD

 

Support Level

Not Supported

Download

com.Slack.Chat_0.10.0.jar

Description

Installation

Steps necessary to enable SlackChat

1. Create WebHook in slack

Picture 1: Navigate to the Incoming WebHooks section under Browse apps - Custom Integrations - Incoming WebHooks

Picture 2: Select the appropriate channel where the incidents should be posted.

Picture 3: Copy the WebHook URL and paste it to the configuration of the plugin


2. Ensure that the Dynatrace Server can communicate with https://hooks.slack.com/ (Port 445) 
3. Enable the SlackChat action on the Incidents you want it to report on.

Configuration in Dynatrace

Usage

Screenshots

Picture 4: Example of how an incident looks in Slack

 

 

 

Contribution

Feel free to contribute any changes on https://github.com/Dynatrace/Dynatrace-Slack-Integration-Plugin

  1. Anonymous (login to see details)

    I am getting "The bundle *.jar is invalid" can anyone help?

     

  2. Anonymous (login to see details)

    Hi Jereme mahaffey which version of Dynatrace are you running?

    I have only compiled it for version 6.3.

    But I have been able to compile for verision 6.2.x also.

     

    1. Anonymous (login to see details)

      I will try the new build for 6.2.x, but I have a test 6.3 that I was getting the issue on.

      Thank you for your responce

      1. Anonymous (login to see details)

        Let me know how it goes!

  3. Anonymous (login to see details)

    That 6.2.5 build isn't working for me, does it work for anyone else? If I open it up in Eclipse it throws errors at me, like "public class SlackChat implements ActionV2" where ActionV2 doesn't exist. Action does, but changing that doesn't seem to help. 

    I also have to go through a proxy to hit Slack, should this respect the system proxy or does it need the proxy info added in the plugin?

     

    Thanks,

    1. Anonymous (login to see details)

      Hi, I unfortunately do not have a 6.2 version to test it on any more. But I have it running on a 6.3 version. It could be that you should go to the github and try to build the verision on your own.

      What kind of proxy settings affects Dynatrace plugins I am unsure of. Whether those be proxy settings from Dynatrace, or from windows / linux OS.

      You can send me a mail if you want to.

  4. Anonymous (login to see details)

    Hi, I unfortunately do not have a 6.2 version to test it on any more. But I have it running on a 6.3 version. It could be that you should go to the github and try to build the verision on your own.

    What kind of proxy settings affects Dynatrace plugins I am unsure of. Whether those be proxy settings from Dynatrace, or from windows / linux OS.

    You can send me a mail if you want to.

  5. Anonymous (login to see details)

    Is there a good link for the 6.3 version? When I download https://github.com/dynaTrace/Dynatrace-Slack-Integration-Plugin/releases/download/v0.9.0/com.Slack.Chat_0.9.0.jar and try to install it I get an error saying the jar is invalid. 

    I've just updated to 6.3 to give this a try.

     

    Thanks,

  6. Anonymous (login to see details)

    I am having same issue as other users have reported. Getting an error saying JAR is invalid. Is there a working version? 

  7. Anonymous (login to see details)

    Hi Abisheak, I am sorry to hear that. Could you maybe send me an Email and I can check if i can solve with you? Ingo Hackl maybe you can help to build it for different versions as that has been an issue before? I only run AppMon 6.3 at the moment.

  8. Anonymous (login to see details)

    I am also getting the invalid jar message. AppMon 6.3.3.

  9. Anonymous (login to see details)

    Now the download for com.Slack.Chat_0.9.0.jar works and I installed this version successfully on Dynatrace 6.2.5 and Dynatrace 6.3.

  10. Anonymous (login to see details)

    Thank you Ingo (smile)

  11. Anonymous (login to see details)

    Does this plugin work for AppMon 6.5.x?

    1. Anonymous (login to see details)

      Yes the plugin works with 6.5.x.

      We have been using it.

  12. Anonymous (login to see details)

    Hi all,

    We have disabled comments on this plugin page.

    Please use the AppMon & UEM Plugins forum for questions about this plugin.

    Sorry to interrupt ongoing discussions. Please re-post your last question in AppMon & UEM Plugins forum.