Comments have been closed on this page. Please use AppMon & UEM Open Q & A forum for questions about this plugin.



See also Visual Studio 2015 Extension.

This plugin only works if used with Visual Studio 2010/2012/2013 Ultimate! If you're using another edition of Visual Studio 2010/2012/2013, please see Visual Studio 2005 and 2008 IDE Plugins.

dynaTrace provides plugins for Visual Studio 2010/2012/2013 to enable Automatic Code Lookups from the dynaTrace Client, Automatic Agent injection when launching an application from the IDE, Integration to the Visual Studio Load Testing Feature.

Plugin Details

Visual Studio Plugin


All you need to do is to

  1. extract the files of the dynaTrace Plugin depending on your dynaTrace version to your My Documents\Visual Studio 2010\Addins directory. If the Addins directory does not exist, create it.
  2. Make sure that the downloaded files do not have the "blocked" file attribute under Windows 7. Change that to unblocked
  3. If running Windows XP, after unpacking the files, it might be necessary to change the file protection to RW.  If VS starts with an error related to this plugin, then the protection isn't set generously enough, or the 'blocked' flag is likely set if on Windows 7.
  4. Now start Visual Studio as Administrator - this is required as the dynaTrace plugin requires access to the registry.  (if on Windows XP, simply set all the plugin files to be RW for all users)
  5. The dynaTrace Visual Studio 2010 Plugin can be enabled through Tools-> Add-In Manager in Visual Studio.
  6. You need to have installed the dynaTrace .NET agent for launcher to work!!

Note: If VS displays an error when starting and disables the plugin, go back to the steps above and verify the file protection issues listed above.

Once the Add-In is loaded you will see two new menu entries in the Tools menu. One is to configure the dynaTrace Plugin (dynaTrace Configuration), the other one is to Launch the currently opened project by automatically injecting the dynaTrace .NET Agent into the launched application (dynaTrace Launcher).

What the plugin provides

This plugin allows you to Lookup Source Code for a method traced by dynaTrace. From the dynaTrace Client you can select a method in the Methods or PurePath Dashlet and Lookup the method in Visual Studio. Please be aware that the code lookup only works for C# Source Code.

The plugin also allows you to launch an application from the IDE and automatically inject the dynaTrace Agent to trace the launched application.

The plugin also extends the Visual Studio Load Testing Feature with a new tab in the Web Test Result Viewer. When you test a web application and the requests made by Visual Studio return PurePath IDs (by using the Web Test Plugin or by specifying "Always send dynaTrace HTTP Headers" in the ASP.NET Sensor) then you can directly lookup a PurePath from the Result Viewer in Visual Studio

Additional Online Documentation: CodeLink AddIn for Visual Studio


Web and Load Test Plugin



  1. dynaTrace Client installed on local machine
    • The plugin drives the session recording via REST calls to the client. The plugin tries to start the client when it is not running
  2. Configuration on the dynaTrace Client (connected server / profiles) already done
    • the settings for the plugin will require a server- and profile name to record a session

Here are the steps to install this plugin:

  1. Download and copy / unzip the dynaTrace Web Test Plugin for Visual Studio 2010 Load Testing depending on your dynaTrace version into your Load Testing Project.
  2. Make sure that the downloaded files do not have the "blocked" file attribute under Windows 7. Change that to unblocked
  3. In your project add a reference to copied / unzipped DLL(s).

In a Web Test Definition

  • Click on the "Add Web Test Plugin" toolbar button select the dynaTrace Web Test Plugin.

In a Load Test Definition

  • Add a Load Test Plugin that will enable Start/Stop Session Recording
  • Attention: the properties "Server" and "SystemProfile" are case-sensitive! Be sure to use the exact string like shown in the dT-Client.

What the plugin provides

The Web Test Plugin will automatically tag Web Requests with the dynaTrace HTTP Header.
The Load Test Plugin will automatically Start/Stop Session Recording during a load test.


  1. Anonymous (login to see details)


    does dynaTrace support VS 2012? or will this plugin work for it?

    1. Anonymous (login to see details)

      We havent tested it yet but we assume it just works as the interfaces should be the same on the VS Side

  2. Anonymous (login to see details)

    Hi Everybody,

    we tried to add the Web Test Plugin to VS2010 Ultimate as described in this article. When performing a test-run, we get the following exception: The File or Assembly "Microsoft.VisualStudio.QualityTools.WebTestFramework, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" or one of its dependencies was not found. The system can not find the file specified.

    The original exception

    1. Anonymous (login to see details)

      Hi Robert

      Can you open a support ticket for this?

      1. Anonymous (login to see details)

        Any update on this? I'm having the same issue.

        1. Anonymous (login to see details)

          Hi Ryan,

          There went something wrong in our deployment process for the Web- and Loadtest plugin. Now a running plugin is available again for 4.2 and 5.

          So please delete all Dlls (dynaTrace.VSTS.WebTestPlugin.dll and Microsoft.VisualStudio.QualityTools.*.dll) from the non-working plugin before extracting the new plugin. You need to reopen your Solution of course.

          Can you give me a short feedback about your success?

  3. Anonymous (login to see details)

    I am trying to load the Visual Studio 2010 add in and when I start VS 2010 ultimate as admin, I get the following error message:

    The Add-in 'dynaTrace Visual Studio 2010/2012 Add-in' failed to load or caused an exception.
    Would you like to remove this Add this Add-in?
    If you choose yes, the file it was loaded from,
    'C:\Users\jpalmiero\Documents\Visual Studio 2010\Addins\CodeLink.AddIn', will be renamed.

    Error Message: <Unknown Error>
    Error Number: 80131515

    1. Anonymous (login to see details)

      Can you try launching Visual STudio as Administrator and let us know if this makes any difference?

    2. Anonymous (login to see details)

  4. Anonymous (login to see details)

    Anyone ever tried dT5.5 + VS2012 Ultimate? The source code lookup simple unsuccessful for me.

    Note that VS2012 is the only IDE I have for .NET, My dynaTrace client running OK from my local laptop, I already check the check box for "connect to CodeLink to dynaTrace" on the dynaTrace Configuration dialog, and I am doing source code lookup from purepath tree for my own code, not for some code come with .NET framework.

    Please advise.


    1. Anonymous (login to see details)

      Hi Flora,

      is your solution (containing the source to lookup) opened in VS when you tried the source lookup?
      Check also if you enabled the REST Web service on your dT-Client (usually on port 8030).
      Please check the log-files of the VS AddIn (in <User-home>\AppData\Roaming\dynaTrace\CodeLinkNet\log) and the dT-Client (<User-home>\.dynaTrace\dynaTrace 5.5.0\log\client) for some suspect entry.

      Best regards,

      1. Anonymous (login to see details)

        Thank you Richard, the log file is very helpful, now it all works OK.

  5. Anonymous (login to see details)

    Do we plan to support Visual Studio 2013? The add-ins are deprecated in Visual Studio 2013 and we have to use VSPackages.

    1. Anonymous (login to see details)

      Hi Jerome,

      I have updated our plugin (Add-in) to be used with VS 2013. It was only a small effort to get it work. As we do not need the advantages of a VSPackage (see http://msdn.microsoft.com/en-us/library/bb330853.aspx) an Add-in is still the perfect solution for VS 2013.

  6. Anonymous (login to see details)

    Thanks Richard. I have installed dynaTrace 5.6 Plugin for Visual Studio 2010/2012/2013 on Visual Studio 2013.

    But I don't see the dynaTrace plugin and I have no menu Tools-> Add-In Manager. Any idea?


    1. Anonymous (login to see details)

      Hi Jerome,

      which edition of VS 2013 do you use?

  7. Anonymous (login to see details)

    I have the Express 2013 for Windows Desktop edition and not Ultimate edition. Is this my issue?



    1. Anonymous (login to see details)

      I was not able to find a comprehensive comparison of features of the VS 2013 editions. I only found an entry at Stackoverflow (http://stackoverflow.com/questions/8953030/where-can-i-get-add-ins-for-visual-studio-express) that confirms your issue.

  8. Anonymous (login to see details)

    I have installed VStudio 2013 Ultimate and the "Open in IDE" does not work: the error messagie is "No connected 'Visual Studio 2005/2008/2010' IDE has been found". However the "dynaTrace Launcher" works correctly.

    Any idea about "Open in IDE"? Furthermore the TCP/IP connection has been established between VS2013 and dT Client on port 8030.

    The process explorer shaows the TCP/IP connection between VStudio and dT Client on port 8030.

    1. Anonymous (login to see details)

      Hi Jerome,

      I've just uploaded a fixed version of the dT 5.6 plugin with a more robust connection handling with the dT Client. Have fun and please respond.

      BR Richard

      1. Anonymous (login to see details)

        Hi Richard,

        The plugin works better

        Thank you

  9. Anonymous (login to see details)

    I have installed and configured the Visual Studio 2010 plugin, but when I select Source Lookup->Open in IDE nothing appears to happen and I see the message "Source lookup was not successful" in the dynaTrace Client status bar. Can you please advise how I can determine what the problem is? 

    1. Anonymous (login to see details)

      The Visual Studio Plugin will communicate with your local dynaTrace Client using REST calls on port 8031. Make sure that this port is allowed on your local installation. You can change the port settings in the dT Client through Settings -> dynaTrace Client -> Services. The port is also configurable in the VS AddOn

      1. Anonymous (login to see details)

        My VS AddOn is configured to connect using port 8030. If I change it to 8031 I get a different message "No connected 'Visual Studio 2005/2008/2010' IDE has been found". Can you please advise?

        1. Anonymous (login to see details)

          8030 is actually correct - it is the NON SSL port where 8031 is using SSL. I will check what engineering has to say

    2. Anonymous (login to see details)

      Hi Andrew,

      is the project containing the class/method you are searching for, opened in VS?

  10. Anonymous (login to see details)


    Hi, We are on Dynatrace 5.5 (new tool for us) and using the Codelink for 5.5, we tried Codelink 5.6 but got the same errors as others.

    My question is , what do you need to have open in Visual Studio 2010 for CodeLink to work?

    If the same line of code exists in several or many files in your application, how does it know which one is being shown in the pure path?


    1. Anonymous (login to see details)

      Hi Sam,

      can you attach some logfiles (found in <userhome>\AppData\Roaming\dynaTrace\CodeLinkNet\log) generated by CodeLink? That may help to identify problems. You should be able to insert more content using this "+" button here and select an Attachment.

      To your question about "same line of code": the look-up just opens the class/method of the PurePath node you performed the source lookup on. If the same method exists more than once, there will be a popup dialog in Visual Studio.

      So I'm waiting for some logfiles.

      Best Regards


      1. Anonymous (login to see details)

        Hi Richard and thanks for the reply.   

        One question you missed, is what should be open in VS for Codelink to find the source code?  I am not a VS user, but the programmers say it does not find anything, but I found a way to make it work, mostly by just trying multiple different locations in VS.

        Found the log files but not much in the V5.6.0.6554 ones.

        2014-04-22 02:37:54 onConnection - ext_cm_UISetup

        2014-04-22 02:37:54 onDisconnection - ext_dm_UISetupComplete

        2014-04-22 02:37:57 onConnection - ext_cm_Startup

        2014-04-22 02:37:57 INFO CodeLink Version:

        2014-04-22 02:38:54 onDisconnection - ext_dm_HostShutdown


        1. Anonymous (login to see details)

          Hi Sam,

          in order to perform a source look-up, the VS solution/projects containing the source code you want to look-up must be opened of course. If there is no project/solution opened, VS does not start to search in source files on your disk.

          So looking at your posted logfile entries there was no look-up performed so far.

  11. Anonymous (login to see details)


    ok, thanks.  I don't know what the programmers were doing wrong in VS but I showed them what I was doing and it worked for them.


    As for V5.6 source lookups, we did do lookups (I think... these were logs from last week), but got the error message "No connected Visual Studio...".

    We are using plugin 5.5 now and that is working for us.

  12. Anonymous (login to see details)


    I found a log file on a pc that still has the V5.6 plug in. ...


    2014-04-11 09:15:58 onConnection - ext_cm_UISetup

    2014-04-11 09:16:08 onDisconnection - ext_dm_UISetupComplete

    2014-04-11 09:16:08 onConnection - ext_cm_Startup

    2014-04-11 09:16:08 INFO CodeLink Version:

    2014-04-11 09:16:16 ERROR when calling CodeLinkConnect. Timeout=True, versionMatched=False, sessionId=-1

    2014-04-11 09:16:18 ERROR when calling CodeLinkConnect. Timeout=True, versionMatched=False, sessionId=-1

    2014-04-11 04:26:08 onDisconnection - ext_dm_HostShutdown

  13. Anonymous (login to see details)

    I'm attempting to use the plugin on 5.6 and I get the following in my log. I don't have VS2010 installed and that appears to be a 2010 assembly.


    2014-05-15 08:16:01 onConnection - ext_cm_Startup
    2014-05-15 08:16:01 INFO CodeLink Version:
    2014-05-15 08:16:01 ERROR System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.VisualStudio.QualityTools.LoadTestPackage, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.VisualStudio.QualityTools.LoadTestPackage, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
    at dynaTrace.VSTS.WebResultAddin.WebTestConnect.OnConnection(Object application, ext_ConnectMode connectMode, Object addInInst, Array& custom)
    at DynaTrace.CodeLink.Connect.OnConnection(Object application, ext_ConnectMode connectMode, Object addInInst, Array& custom)

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].




  14. Anonymous (login to see details)

    1. Anonymous (login to see details)

      Thanks for pointing this out. It seems like this video asset was not moved from dynatrace.com to compuware.com and is lost (sad) - i removed the link

  15. Anonymous (login to see details)



    We are trying to get the plugin to work on Windows 8, Visual Studios 2012 ultimate.  We are seeing the PurePaths in dynaTrace, but not seeing them tagged with the test names.  We looked at the configuration of the plugin in VS, and the .dll is showing in the references, the server name and system profile have been set.  The rest interfaces of the client are responding over the same port we have configured in VS.  We are not seeing any additional headers being sent in fiddler sessions when comparing with/without the plugin.  


    It appears no log file is being generated in the mentioned " <userhome>\AppData\Roaming\dynaTrace\CodeLinkNet\log" directory.  


    Has anyone else had success using this on Windows 8?

    1. Anonymous (login to see details)

      Hi William,

      so for me it's unclear what you want to achieve exactly using the VS plugin? This plugin supports injection of the .NET Agent (but only for e.g. IIS Server > use the ".NET Agent Config tool") and the source lookup starting from a PurePath node in the dT Client. Why do you think Windows 8 is doing some trouble here?

      BR Richard

      1. Anonymous (login to see details)

        Hi Richard,

        I am looking at the Web and Load test plugin.  The plugin states it is supposed to add the tags for mapping the load test steps to the requests going to the applications.  The end goal would be to have the "Load Test Overview" dashboard populated with the visual studio tests.  Currently it appears the plugin on windows 8 instance at the client is not adding the tags to the request.  I am wondering where we could look for that.

    2. Anonymous (login to see details)

      Hi. I assume you added the web test plugin to your load test? When executing a test run and then looking at the Web Test Results in Visual Studio where you see each individual web request: can you spot the X-dynaTrace HTTP Header?

      The Web Test Plugins job is to add this header to the request. Visual Studio should then show you this HTTP Request header. If the header doesnt show up we know there is something wrong with the plugin. If the header DOES show up but you still see no tagged web requests in dynaTrace we know that some components (proxy, firewall, ...) between your visual studio load generator and the application server strips that HTTP header


      1. Anonymous (login to see details)

        Hey Andi,

        Yes the web test plugin .dll was added to the project and is a part of the references as stated in the install steps.  We do see the configuration dialog and have set it to the right dynaTrace server/system profile.  When we ran the test, we see the transactions showing up in the dynaTrace client but they HAVE NOT been tagged with the test IDs.  We captured some outgoing fiddler sessions and the x-dynatrace header is not in the outgoing transactions.

        We are using VS 2012 on Windows 8.  I am wondering if the OS is causing some issues?

        Also, do you need to install both plugins (VS Plugin and the Web Test Plugin) in order for this to work properly?


  16. Anonymous (login to see details)

    Just to be clear, the way this works is that the source code must be sitting on the machine and be open in Visual Studio before doing a source code lookup? What if some of the source code is lying elsewhere another box or in a different environment....as long as its accessible by the machine running VS it should be ok? When you say the .NET agent must be installed, do you mean on the machine running VS?

  17. Anonymous (login to see details)

    I tried this plugin at a customer site. They are using VS 2013 Ultimate and DT 6.1. Even after adding the files to the "My Documents\Visual Studio 2013\AddIns" directory, the dynatrace plugin does not show up in the AddIn Manager. The customer did start the VS as an administrator. Any thoughts? 

    1. Anonymous (login to see details)

      Did you change the file attributes from blocked to unblocked?

      1. Anonymous (login to see details)

        I looked for the file attributes for CodeLink.dll but did not find the unblock option. 

        1. Anonymous (login to see details)

          Have you also tried doing it for the CodeLink.resources.dll in the dynatrace folder?

  18. Anonymous (login to see details)

    Is it possible to populate the Test Name and Script Name fields of the Tagged Web Requests dashlet with the VS web/load test plugin? We only can get the Timer Name to populate and it doesn't seem like there is anywhere to get these other fields to populate.

  19. Anonymous (login to see details)

    Any plans to support VS 2015? I have a prospect who is asking if we support this and in general, how long after an update to VS before this plugin supports it.

  20. Anonymous (login to see details)

    Is there a reason the plugin only works for Ultimate edition?  I have a customer who uses 2012 premium and is looking for this integration.

    1. Anonymous (login to see details)

      If I remember correctly the integration with the load testing feature required it - but will have to check on that. Which functionality does your customer want to use?

      1. Anonymous (login to see details)

        Yes, you're right Sonja.

        If you don't need the load testing features, but only the CodeLink and launcher, please use this version of the plugin: Visual Studio 2005 and 2008 IDE Plugins It should work with Premium edition.

        The load testing features make use of libraries that are included in the VS Ultimate edition only.

        1. Anonymous (login to see details)

          So if I have 2012 Premium edition, I would use the 2005 and 2008 IDE plugin, correct?

          1. Anonymous (login to see details)

            Yes, that's correct!

  21. Anonymous (login to see details)

    Is there a plan for Visual Studio 2015 support?

    1. Anonymous (login to see details)

      yes - we are planing to start a research task soon to see how much work an update to Visual Studio 2015 would mean in terms of effort and which use cases we want to cover in the future for that integration.

      Which features are most interesting for you? Code Lookups from the dt Client? Automatic Agent injection when launching an application from the IDE? Integration with Unit Tests? Integration to the Visual Studio Load Testing Feature?

      1. Anonymous (login to see details)

        Thank you for the fast reply! Currently we are most interested in the integration to the Visual Studio Load Testing Feature since we're checking if we want to build up a load testing environment with VS 2015.

      2. Anonymous (login to see details)

        I have a very large customer that is using VS2015. They would love this!

  22. Anonymous (login to see details)

    We have just started using Dynatrace and I am jumping on the VS2015 Wagon. There are instructions on creating your own add in or VS but it's the one Andreas wrote for VS2010. VS2015 has totally changed how to create VSIX/VS Packages so the article is no longer valid but pretty sure you can use it as a guide to creating your own extension.  I would LOVE for Dynatrace to upgrade the add in and webplugin for VS2015 -we very much have to stay within the MS Stack and I am sure there are countless other Dynatrace customers who are working in VS2015 and would love this extension.

    Do we have a timeline on when the VS2015 extension and webtest plugin's will be available?

    1. Anonymous (login to see details)

      Hi John - the development is in progress. As you noticed yourself, VS2015 changed the way we develop extension, so it takes a little bit more work to upgrade the plug-in. Timeline for the VS2015 extension is around the end of the month. 

  23. Anonymous (login to see details)

    Hi all,

    have a look at Visual Studio 2015 Extension. Make sure to provide feedback as this is just the first version.


    1. Anonymous (login to see details)

      This link takes you to the plugin page for previous versions and the link to the 2015 plugin on THAT page doesn't work -it's recursive as it links to the same URL for the page you are on (2010 to 2013 plugins).

      Can you provide the correct link, or was the VS 2015 plugin pulled back from release?




      1. Anonymous (login to see details)

        Seems it was a problem with the permissions, should be fixed now - please try again!

  24. Anonymous (login to see details)

    Hello - we tried to use the plugin with our Visual Studio 2013 and dynaTrace 6.3 installation. But when we build the project with the "dynatrace Launcher" entry we are getting this error message: "Could not launch application with dynaTrace support: Cannot start process because a file name has not been provided."

    When we start the application in the normal build process with the dynaTrace agents everything is working fine.

    1. Anonymous (login to see details)

      Hello Friederike,

      What application/project type are you trying to execute?


      Best regards,

      Wiktor Bachnik

      1. Anonymous (login to see details)

        Hello Wiktor,

        it is a .Net Webapplication as far as I know. .Net Version v4 with IIS .

        Currently I've no access to the environment but if any other infor will be helpful I can request it.

        Best regards,