Information:

Environment

Any supported browsers, see documentation for details.

  • dynaTrace

 

Symptoms

The Browser Agent is installed and the dynaTrace Browser add-on/toolbar has been enabled from "Manage Add-Ons" in the browser, but the dynaTrace toolbar is still not visible in the browser.

Solution

After enabling the Add-on for dynaTrace, to see the dynaTrace toolbar, you must go to the View menu in the browser, click Toolbars, then find and select "dynaTrace Toolbar".

Now it appears and you can connect to dynaTrace.

If you click to connect to dynaTrace and later find that the Agent Mapping is incorrect, you'll find that the Agent Mapping field is grayed out and cannot be modified. Simply close the browser and re-open it to disconnect from dynaTrace so that you can modify the Agent Mapping, then click Connect.

Additional information regarding the Browser Agent can be found on http://apmcommunity.compuware.com.
Once logged in, go to the following links:

https://apmcommunity.compuware.com/community/display/DOCDT50/Browser+Agent+Configuration
and
https://apmcommunity.compuware.com/community/display/DOCDT50/Browser+Diagnostics

Root Cause

The Browser's toolbar must be enabled via the View->Toolsbars menu.

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