Information:

Environment

AppMon: 3.x

Symptoms

 

The agent connects briefly, then disconnects.
The following error is observed in the agent log:
=======================================================
2010-04-27 09:46:15 severe [native] Exception while connecting to collector, info:<Could not register agent with collector due to unknown response code 842149933>
2010-04-27 09:46:15 fine [native] pnapi::Connection::connect() ... set socket timeout to 30000000 microseconds
2010-04-27 09:46:15 fine [native] Socket timeout set to 60 for handshake
2010-04-27 09:46:15 fine [native] pnapi::Connection::receiveExact() ... apr_socket_recv()->70014/End of file found
2010-04-27 09:46:15 fine [native] Connection::close()
2010-04-27 09:46:15 fine [native] Connection::close()
2010-04-27 09:46:15 fine [native] Client::Register() — EXCEPTION: rv:70014, info:<receiveExact(), 70014, End of file found>
2010-04-27 09:46:16 fine [native] Client::connect(): connecting
2010-04-27 09:46:16 fine [native] pnapi::Connection::connect() ... start
=======================================================

 

Solution

 

This problem can occur from having another process already bound to the agent listen port. The AppMon Collector/Server listens for agent connections on port 9998 by default. If the dynaTrace Collector/Server fails to bind to port 9998, this can be observed in the Collector/Server log file by a message such as:

 

Failed to initialize agent center. Probably the port 9998 is already in use.

 

This problem has been observed on Unix/Linux machines when the Uptime Agent is being used. The default port for the Uptime Agent is also 9998. If you are using the Uptime Agent, we suggest changing the port of either the Uptime agent or the AppMon Collector/Server so as to avoid the conflict.

Root Cause

Uptime agents default port 9998.