Compuware APM Recorder



My Compuware APM Recorder playback function is not working well. How can I troubleshoot it?


When Compuware APM Recorder playback function is not working well, please try the following troubleshooting steps:

Step 1. Clean Reinstall Compuware APM Recorder

Uninstall Recorder, delete related directory such as User directory (C:\User\Data\..\Application Data.), then install again.

Step 2. Installation Permission (Windows Vista and up, Windows 7, Windows 2008...)

a. Install Recorder using admin privilege
b. Startup Recorder using admin privilege
c. Install Recorder just under C:\

Step 3. Directly start up the Agents (also monitoring Event log when you click on the agent executable files, please clear the event log first if possible).

a. FF Agent

First, please go to "C:\Program Files\Compuware\Recorder\playback\Firefox" and try to click on Panzilla.exe, see if it pops up or in the taskbar.

Second, please go to "C:\Program Files\Compuware\Recorder\playback\Firefox\gomez-tools" and try to click on panzilla-launch.cmd, see if it pops up or in the taskbar.

b. IE Agent

Please go to "C:\Program Files\Compuware\Recorder\playback\IE" and try to click on GomezIEAgent.exe, see if it pops up or in the taskbar.

Step 4. If there is proxy, please set the same proxy for Recorder with IE.

Step 5. Please check your Environment information (OS, browser, software installed, any security and antivirus software or company policy).

a. Disable certain security software
b. IE Security Settings (recommended to set Medium-High or below)
c. Start Windows in safe mode or using selective start up services
d. In Anti-Virus software, we need to add exception to the anti-virus software allow the following process to run.

• Allow Panzilla.exe
• Allow plugin-container.exe
• Allow GomezIEAgent.exe
• Allow Recorder.exe

Step 6. Port examination to see any port is blocked

a. Play back with Firefox -- remote port tcp 8100
b. Play back with IE -- remote port tcp 7777

Root Cause



Error rendering macro 'kbsurvey' : null

  • No labels