Enter Case number reference for associated cases.

Case #

Status:

Type: Enterprise

Old Article ID: 4684

Old Article Type: howto

If you have access to the internal dynaTrace Wiki, see this list of debug flags for possible values:
https://wiki.dynatrace.local/display/DEV/dynaTrace+Collector+Options

Information:

Detail the contextual information specific to the issue; i.e. Product, Version, Agent, System, etc.

AppMon: 4.2+

Describe the problem, from the user perspective

This how-to is applicable when a support engineer asks you to enable or set a AppMon collector debug flag

Clearly list the Steps to resolve the issue

  1. Enable DEBUG mode in the AppMon client by hitting Ctrl+Shift+F9 (Cmd+Shift+F9 on Mac). Make sure that no modal dialogs are open. You should see the string "DEBUG" in the status bar like in this example:
  2. Go to Server Settings -> Collectors, select the appropriate collector and hit Debug Flags...
  3. Enter "Key" and "Value" as specified (Value is usually 'true') and hit the "Add" button.
  4. Press the "Apply" button of the "Dynatrace Server Settings" dialog to save the setting.
  5. Depending on the debug flag, a restart of the collector may be required.
  6. Verify that the debug flag is active by looking for additional log messages. If you have doubts that the debug flag is active, check the dtcollector.ini file:
    - If the debug flag doesn't appear there, either add it manually or repeat the process outlined above.
    - If it is there but occurs after the -Xrs flag, please move it up so that it's in the section where all the other -D definitions are.