cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

About usessl setting to AppMon v7 agent (java / httpd)

dt_its3-1
Inactive

Hi,

The Dynatrace AppMon v7 manual contains the usessl setting of dtwsagent.ini.
However, it seems that WSAgent (v 7.0.0.2469) I installed does not find the "usessl" setting in dtwsagent.ini.

"usessl" is add write directly in dtwsagent.ini?
Or does not support "usessl" in this version?
Sorry for the simple question..


Best Regards,
Takunobu Atsukawa

4 REPLIES 4

ryan_shaw
Dynatrace Helper
Dynatrace Helper

Hi,

I've configured this before although I can't check the settings currently. I belive it is set inside <DT_HOME>/init.d/dynaTraceWebServerAgent and you add the variable DT_USESSL=true where the other variables (such as DT_RUNASUSER) are set. Restart the primary agent and this should configure SSL, you can double check it's set in the agents overview in the details pane.

 

dt_its3-1
Inactive

Hi Ryan,

Thank you for your answer.

If I want to set isMasterAgentServiceInstalled in dtwsagent.ini to false,I can't use usessl parameter?

Also,in the case of Java,I understand that ssl becomes usable by adding "usessl=true" to "-agentpath:~", Is it suitable as a method?

Sorry about varios questions.

Best Regards,

Ta

I'm not sure if it's possible if you set the isMasterAgentServiceInstalled to false, I'd guess not.

For java that's right, just add it to the end of your argument with a comma and it should work 🙂

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Be aware, usessl= is only available starting in AppMon v7.