cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Agent 6.2 to 6.5 upgrade question

johnroncaglione
Organizer

We are in the process of upgrading from Dynatrace 6.2 to 6.5. After testing it looks like the controlled roll out feature and the unchecking the automatic agent update feature is not working. The 6.2 agents are still downloading the 6.5 files. If we keep the agent on bootstrap version 6.2 is there a way to prevent it from downloading the 6.5 update through the client instead of changing to point to the "dtagentcore.dll"?

If we do have to reinstall the agent to version 6.5 can someone clarify if this line from another post I found is true or not?

"reinstalling the agent that means will we loose all the measures and data configured previously for that agent"

3 REPLIES 3

Babar_Qayyum
Leader

Hello John,

To use the 'unchecked / disabled the automatic agent update feature' has the following requirements / prerequisites.


  • A bootstrap Agent with version equal to or later than 6.3.
  • The bootstrap Agent must have been connected to a Collector with the version you want to use.

Regards,

Babar

Babar,

Does the controlled rollout feature also require bootstrap version 6.3 or later? I thought it was supposed to prevent the agent upgrades starting with bootstrap version 6.0.

Thank you

John

Hello John,

To successfully install an update on an Agent when performing a controlled update rollout, the Agent must meet the following conditions:

  • The Agent must be a bootstrap Agent.
  • The version of the bootstrap must be at least 6.0.0.

Regards,

Babar