cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Agent Cannot Connect to Collector: temporary failure in name resolution

We're trying to connect an Agent to a Collector, but the bootstrap log file for the Agent keeps showing this issue.

It looks like the DNS can't resolve the server name into a reachable host. We tried using the IP address directly, but the log file then showed "network is unreachable".

We then used ping to show that the Collector host is reachable from the Agent host. We used both the domain name and the IP address, and both worked when using ping.

Can anybody help with figuring out why this would occur? I would assume that there might be firewall rules in place that are blocking TCP connections on 9998 or 8043, but we checked to make sure those ports were open for TCP and UDP.


2 REPLIES 2

We also tried using the IP address of the collector host directly, but we got "Network is unreachable"

We know the network is available between Agent and Collector as we are able to communicate via ping and wget commands between them on port 9998.


Turned out that the firewall was indeed blocking the Agent on port 9998. We had to fully disable the firewall in order to get the Agent connected to the Collector.

on Red Hat Linux, the command we used to do this was:

systemctl disable firewalld.service

So the lesson is that even if you think the firewall is open and even if ping and other commands are making it through on that port, it may still be blocking the Agent connection.