cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Agent Compatibility

juan_baena
Organizer

Our dynatrace collector servers are running version 6.1.xxx and as we work in configuring new windows servers for our web application we were considering installing the dynatrace agent 6.2 provided its backward compatible with a dynatrace collector version 6.1.  Are there any known issues, should we install the 6.1 dynatrace agent rather than 6.2 so we remain consistent with the collector version? Thanks

3 REPLIES 3

andreas_grabner
Dynatrace Guru
Dynatrace Guru

Hi

Why would you want to just upgrade the agent? We have a bootstrap feature that will take care of a correct automatic rollout of new dynatrace versions.

If you install a new version of dynatrace you normally do it through a regular upgrade or fixpack. This will also ask you to restart your Collectors so that the collector automatically updates to the latest version. After that you can restart the agents and they also automatically get the new version

 

juan_baena
Organizer

As a customer/consumer of Dynatrace we do not have control over the collector/server version.  The dynatrace collector is leverage by many applications, we are just one of them and it gets updated to newer dyntrace builds when possible.  At this time we have not heard yet plans in upgrading the 6.1 dynatrace collector to 6.2.

Since we are working on brand new windows servers where our web site will reside, we are not doing dynatrace agent upgrades but looking at a brand new installation. Because its a new agent installation we thought perhaps installing the latest agent version.  Perhaps we should just install the dynatrace agent 6.1 so its compatible with the 6.1 server collector.

andreas_grabner
Dynatrace Guru
Dynatrace Guru

When installing a new agent you should choose the version that your dynatrace server has. If you install a new version as I mentioned above Dynatrace will guide you through the upgrade process. A new version is always installed on the dynatrace server and then rolled out to the collector and agents through our automatic update/bootstrap mechanism. 

It doesnt make sense to install a newer version of an agent and let it connect to an older Collector. Once the collector gets upgraded the agents will also be upgraded automatically when the app is restarted

So - in your case - just install whatever version runs on your dynatrace server. then you are good