cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Agent did not connect or did not find matching profile. Please make sure that agent can connect to collector, and that agent settings system profile name is valid

This is what I found on my log


2016-11-11 11:32:45 [0000036c] info [native] Dynatrace Bootstrap Agent 6.5.0.1289

2016-11-11 11:32:45 [0000036c] info [native] Using c:/dynatrace as Agent storage

2016-11-11 11:32:45 [0000036c] info [native] Log file is d:/dynatrace/agents_bootstrap_3308.0.log
2016-11-11 11:32:45 [0000036c] info [native] Trying to connect to Collector for up to 20 seconds
2016-11-11 11:32:55 [0000036c] info [native] Error connecting: connect()/apr_socket_connect(), 730060, Connection timed out
2016-11-11 11:32:56 [0000036c] info [native] Error connecting: connect()/apr_socket_connect(), 730061, Connection refused

2016-11-11 11:33:06 [0000036c] info [native] Error connecting: connect()/apr_socket_connect(), 730060, Connection timed out
2016-11-11 11:33:07 [0000036c] info [native] Error connecting: connect()/apr_socket_connect(), 730061, Connection refused

2016-11-11 11:33:08 [0000036c] severe [native] Unable to connect to Server/Collector. Last error was: No connection could be made because the target machine actively refused it. (730061)

2016-11-11 11:33:08 [0000036c] warning [native] Unable to register with Server/Collector

*IP *

2016-11-11 11:33:08 [0000036c] info [native] Checking availability of binary of last used version of agent Cloud_UEMaaS[dec54a9a-8516-4e95-91c8-b75b809bbaf0] (windows-x86-64/dtagentcore.dll)

2016-11-11 11:33:08 [0000036c] info [native] Look for persisted version of agent Cloud_UEMaaS[dec54a9a-8516-4e95-91c8-b75b809bbaf0] (windows-x86-64/dtagentcore.dll) in file 'c:/dynatrace/agent/conf/agentversion.Cloud_UEMaaS[dec54a9a-8516-4e95-91c8-b75b809bbaf0]'

2016-11-11 11:33:08 [0000036c] info [native] Persisted agent version for Cloud_UEMaaS[dec54a9a-8516-4e95-91c8-b75b809bbaf0] (windows-x86-64/dtagentcore.dll) not found

2016-11-11 11:33:08 [0000036c] info [native] Agent binary not found. Looking for latest local agent binary.
2016-11-11 11:33:08 [0000036c] info [native] Latest agent binary found is c:/dynatrace/agent/downloads/6.5.2.1012/native/windows-x86-64/dtagentcore.dll

2016-11-11 11:33:08 [0000036c] info [native] Loading Agent c:/dynatrace/agent/downloads/6.5.2.1012/native/windows-x86-64/dtagentcore.dll

2016-11-11 11:33:08 [0000036c] info [native] Persisting current loaded version 6.5.2.1012 of agent Cloud_UEMaaS[dec54a9a-8516-4e95-91c8-b75b809bbaf0] (windows-x86-64/dtagentcore.dll) to file 'c:/dynatrace/agent/conf/agentversion.Cloud_UEMaaS[dec54a9a-8516-4e95-91c8-b75b809bbaf0]'

9 REPLIES 9

Radu
Dynatrace Pro
Dynatrace Pro

Hi Sajidh,

A few points:

  • What type of agent is this? (java, .net, webserver, etc.)
  • Has this agent been able to previously connect to the collector?
  • Is the agent name matching the agent group mapping pattern?

As the log says, the collector machine refused the agent's request to connect.

hi , its a .net agent , and yes it was working perfectly till wednesday since our servers got recycled on thursday i had to restart and configure the agents but now it gives me this error

Can you edit the configuration and confirm that the address and port of the collector are the correct ones? (You can verify this against the collector details in the Dynatrace Server settings)

peter_karlhuber
Dynatrace Pro
Dynatrace Pro

The log states "Connection refused", which would mean that either the host address / ip address or the port number is wrong for the collector, or the collector isn't up, or some firewall prevents the connection.

Hi Collector is up and one agent connected but the others are not they have the same error above

Hi Sajidh,

please verify that a

telnet <<IP of collector>> 9998

works from the machine where the agent is installed (i.e. doesn't throw a "connection refused").

If this works, there's some problem with either the collector or the agent and you need to open a support ticket. If that doesn't work, it means that there might be some firewall or another network related issue. Best regards,

Peter

Hi finally managed to get it working , it was trying to connect to the internal IP in the azure cloud rather than the public IP , so edited the collectorlist and added the public IP there , and it works fine now


thank you for the suggestions 🙂

Hi Sajidh,

Currently we are also facing the same .net agent disconnection issue.Kindly share your resolution over this problem & How exactly you implemented those changes to resolve this issue.

dt-dtwsagentexe-12560.log

dt-dtwsagent-bootstrap-12560.log

Thanks & Regards,

Ruchita Terse.

even though it worked i dont think it is the solution because i tried doing the same in a test environment it ddnt work , but telnet to collector IP works