cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Agent instrumentation is not available

mayana_s_khan
Inactive

Hi,

We are facing issue with java agents, Agents are connecting with instrumentation not available state.

We have tried restarting of services, added wait=10 parameter to JVM, ports are open between agent, collector and server.

The "Mgt" entries are updating in the collectorlist<agnetname> file in /<DT home>/agnet/conf. we clear the list and restart the application and collector still we have the same issue.

We have more licenses in environment

img.jpg

Regards,

Mayana Khan


3 REPLIES 3

kyle_kowalski
Dynatrace Pro
Dynatrace Pro

You say that theports are open between the collector and the agent, are they on the same subnet? What is the latency?


Babar_Qayyum
Leader

Hello @Mayana K.

Telnet the port (default 9998) from agent host to collector if it is OK then in the agents overview dashboard right click on the top and add the below columns to make sure the instrumentation time in avg and max (avg should be less than 100 ms).

  • Average Instrumentor Response Time (ms)
  • Maximum Instrumentor Response Time (ms)

A firewall introduces latency in the calls between the Agent and Collector. This is often the reason for slow application start-up. The Agent needs to do several 10,000 round trips to the Collector at application start up. Even 1 ms firewall latency adds up to a noticeable time. Therefore, either use a real fast (in latency time) firewall or put the Collector into the same subnet as the Agents.

Have a look on the below link for the collector best practices.

https://www.dynatrace.com/support/doc/appmon/insta...

Regards,

Babar


dan_m_smith
Helper

What do you see when you right-click, Details on the Agent(s). Is Collector Low on Memory there. Increase the collector heap if that is the case.