cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Agent is Connected but have some issue (Issue: Instrumentation is not available.) Due to this not able to capture any data from agent.

supriya_kamble
Participant

i checked the JVM argument it is proper. After one restart of app server this issue is occur. please find the attachment for this issue.

6 REPLIES 6

supriya_kamble
Participant

Is this issue surely resolve by taking the server restart???

Hi Supriya,

Is there a firewall between collector and servers(agent placed)?

Thanks

Soorya Mohan

sooryaprabha_mo
Inactive

Hi,

As per logs, when you did JVM restart collector/server is not available to handle the agent connection, at the time agent will wait for particular seconds for license , at this time if it gets connection it will do license confirmation , so agent connection will happen and leaves without instrumentation.

So restart of agents again will solve this issue.As its a JVM , you can restart JVM + agent. please make sure that dynatrace server/collector is up and available.

Thanks

Soorya Mohan

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello @Supriya K.,

I guess there is huge latency between agent and collector/server due to firewall or your local network.

Just add wait=5 in the end of your JVM argument and then restart the application or you can increase the time in case you face the same problem.

Regards,

Babar

supriya_kamble
Participant

We have already added wait=60 in the end of JVM argument still faced this issue.

Hello Supriya,

Add the following two columns from the header of the Agents Overview dashboard and check the instrumentor time of avg and max and share the screenshot.

Regards,

Babar