cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Android Auto instrumentation for infra modules

yariv_harel
Newcomer

While Trying to add the android gradle plugin for auto instrumentation in an infra module (framework module)

I got "Extension of type 'AppExtension' does not exist.

I want to add the Dynatrace library in an infra module so I will be able to use it in one place instead of adding code in each flow.

@yosin@matrix.co.il

1 REPLY 1

Thomas_Wirth1
Dynatrace Pro
Dynatrace Pro

I'm not familiar with infra modules, but maybe this general information help you.

The Dynatrace Gradle plugin modifies the Android build process and therefore needs the Android Gradle plugin. The extension AppExtension is provided by the Android Gradle plugin.

Possible reasons for your error could be:

* The Android Gradle plugin is not part of the build script

* You are building an Android Library and not an Android App