cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Android Gradle Dynatrace Plugin 7.2.4.1262 fails to sign APK using Android Gradle Plugin 3.5.0

shane_raiteri
Newcomer

Hi all,

We're currently in the process of upgrading our project to support Android Gradle Plugin 3.5.0. During the ./gradlew autoInstrument{Variant} steps, it seems the AndroidBuilderTask required by the Android Gradle Dynatrace Plugin (7.2.4.1262) has been removed.

Caused by: org.gradle.api.GradleException: Failed to sign apk
        at com.dynatrace.tools.android.AutoInstrumentTask.instrument(AutoInstrumentTask.java:356)

...

Caused by: java.lang.ClassNotFoundException: com.android.build.gradle.internal.tasks.AndroidBuilderTask
        at com.dynatrace.tools.android.AutoInstrumentTask.instrument(AutoInstrumentTask.java:191)

Is Android Gradle Dynatrace Plugin 7.2.4.1262 compatible with Android Gradle Plugin 3.5.0 yet? If not, is there an expected ETA or an support article to workaround this issue?

Regards,

Shane.


2 REPLIES 2

Thomas_Wirth1
Dynatrace Pro
Dynatrace Pro

Dynatrace Gradle plugin version 7.2.4.1262 is not compatible with Android Gradle plugin 3.5.


The new major version of the Dynatrace Gradle plugin is compatible with Android Gradle plugin version 3.5 and support the new feature "Apply Changes". But it is currently only available as EAP version: https://www.dynatrace.com/news/blog/announcing-new-and-super-fast-android-auto-instrumentation-eap/


shane_raiteri
Newcomer

Thanks @Thomas W.! We'll wait for the next major version to come out of EAP, and signup for preview in the meantime.