cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

AppMon don't have any UEM

asruinoiua
Contributor

Hi everyone,

I have Dynatrace AppMon monitor a website. It run dotNet and SQL 2012.
I installed dotNet agent, IIS agent, SQL agent and it worked perfectly, the Purepath is still analyzed.

But AppMon do not have any UEM of user visit my website. I checked JS agent loaded successful when user load any page of my website.

How can i determine the problem?
I've tried reinstall but the problem did not resolve.
Please help me, thank you very much.

17 REPLIES 17

hao-lin_liang
Helper

Hi,

Have you checked your system profile to see if UEM is turned on. If you click on the user experience section on the left you should see this. At the top under capturing, check where the scroll is under, if its in the middle or on the left you will not get any UEM data, make sure it the scroll button is set to the right like in the screenshot above.

Hao-lin

Yes, i configed with default setting.

I installed two .net sites with the same configuration, the other one was not.

Please try the UEM Health check Andi and I suggested, this will check for the common sources of problems.

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

pahofmann
DynaMight Leader
DynaMight Leader

I would start by doing a UEM Health Check.

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

andreas_grabner
Dynatrace Guru
Dynatrace Guru

There is a great tool within the Dynatrace AppMon client called "UEM Health Check" - I would give that a try as it can point you to different sources of problems: https://community.dynatrace.com/community/display/...

Most prominent would be

#1: configuration glitches

#2: licensing issues, e.g: maybe you ran out of UEM Licenses

#3: Firewall blocking /dynaTraceMonitor signal

Andi

Hi Andi,
How can i check "firewall blocking /dynaTraceMonitor signal"?

Take a look at your firewall logs if possible. If not you can try to reach the /dynaTraceMonitor Endpoint on you webserver in a browser and see if you get a result.

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

To add to what Patrick said: All the items I listed (and even more) are automatically checked by the UEM Health Check tool that you can find in your Dynatrace AppMon Client

asruinoiua
Contributor

Thank you very much.

I think I know where the error is. When i check UEM by Dynatrace Client:

And i see detail:


  • JavaScript Agent URL/File Name Malformed - The URL of the injected JavaScript Agent is malformed. The correct URL / file name of the JavaScript Agent should look like this: dtagent_ax_6000500005176.js. This may occur if you inject manually, or delete a JS plugin

but i dont know how to fix it?
Can you help me please?

Hello Asrui,

Can you check the 'User Experience' sensor pack properties for the injection point settings?

What are your location settings?

Do you get the similar result after accessing the monitor request path?

Regards,

Babar

Yes, User Experience sensor pack properties of IIS is "automatically inject JavaScript agent into HTML".
And Location settings of User Experience:

And when i access to Agent location:

access to Monitor request path:

Hello Asrui,

When I access the https://www.don.com/ then the dtagent634_egjpqt_1034.js is loading but when I see to your shared agent location and the access to agent location they both have different versions.

It means you have a configuration problem.

Can you double check with you?

Regards,

Babar

asruinoiua
Contributor

Hi everyone,

Sometime, it still monitor, but not all.
My website have 2000-3000 visits / day. And today it analyzed 1 visit.
It seems unstable.

Hello Asrui,

Is this the internal user who accessed the website or external?

Check the 'Client IP' on the same screen.

Regards,

Babar

Hi Babar,
I checked. This is external IP.

Hello Asrui,

UEM uses some HTTP technologies to send performance data from the browser to the AppMon Server. To do this, JavaScript Agent code injects into your HTML pages. This code communicates with the web server or Java Agents, which forward collected data to the AppMon Server. To fully enable UEM, however, you must verify that your firewalls, proxies, and web servers are configured properly.

Please read and share the following information with your security team to understand the UEM requirement.

https://www.dynatrace.com/support/doc/appmon/user-experience-management/user-experience-management-administration/firewall-constraints-for-uem/

Regards,

Babar

asruinoiua
Contributor

hi everyone,

This error still occurs.

I just tried reinstalling the agent for the my web server and result when i checked with UEM Health Check:

Everything looks good. But i don't know why UEM not work.
Please help me!