cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Appmon 7 - How to chart RT, Throughput and Failure rate for business transactions(aggregation hr)?

Hi, I am trying to get this kind of view for a Business Transaction in Appmon.

Looking for a solution to find the response time (avg or p95), throughput and failure rate of each business transaction for every hr in the last 7 days or 15 days. Also, when I show the threshold line on graph, it would be easy for me to pull the metrics with the TP count > 5. Please help me with how to chart with a threshold line.

I am able to get this view but the failure rate or count is missing. Appreciate your help here. Thanks, Suresh.



10 REPLIES 10

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Suresh, I'm not sure I understand how you've setup your BT, but generally you need to add additional items to the 'Calculate Results". There's shortcut checkmarks for Failure Rate and the Response Time & Count metrics. Once these are calculated for the BT, then you can chart them as additional metrics under the BT heading.

Let us know if you've done this.

As for charting a threshold, did you set the threshold on the associated measure? Then select that threshold to be included in the chart.?

Thanks @Joseph M. H., This is how I created the Business transactions


When I plot the three metrics, RT, TP, and Failurerate in the chart I can show the Threshold line. The issue here is, Y-axis unit doesn't make sense as I am plotting Time and count in the same axis. another challenge, I am not getting Table view that I expected.

If I go with a dual-axis chart, I can't show the threshold line, isn't? I did not find that option with dual-axis. So, please suggest me the best option to get a table view and to show the threshold in the chart.

Hi @Joseph M. H. any suggestions from below snapshots? thanks, Suresh.

Dual-Axis charts cannot display thresholds as there's no way to determine which axis the threshold belongs. Another approach is to simply put the measures on a normal chart (not dual-Axis), then split by Measure. This gives you a separate chart for each measure, and will allow you to select 'Show Threshold'. If you do this, you might need to edit the chart and in the AXIS tab, unselect "Share Axis bounds for spit charts", else the axis will be locked together which might not look good.

sounds like a good idea @Joseph M. H. will give a try and let you know. thanks

Hi @Joseph M. H. if you can, could you please show me with an example and some screenshots with the measures? Able to visualize what you suggested but not able to implement 😞

Here's a sequence of steps. I skipped some steps that I think are obvious. But if something seems missing let me know and I can provide more detail for those steps.

1) Create new chart and add require measures to the chart.

2) Edit the Dashlet properties and select AXIS tab, uncheck "Share AXIS bounds for split charts". (Screenshot 1)

3) In the upper right corner of the chart, select "Splitting" menu, select "Measure". (Screenshot2)

4) I also cleaned up the legend a bit (removed the unnecessary fields). The measure I picked wasn't a good one as it does not have any thresholds defined, but select the "Show Thresholds" checkbox to have them displayed.


Let me know if that helps.

Thanks @Joseph M. H. few observations from the chart


TP - Throughput chart (user action count). I am ok with the Y-axis here

RT - Response time chart. It is picking the same range for Y-axis as TP chart (how to adjust that? If I change upper and lower bounds it's changing for all )

Fail cnt -> Failed count of requests. Y-axis is same as TP chart. need to adjust the Y-axis range.

If you look at the values of the measures, Count is showing same for TP count and Failed requests. Seems I need to add one more filed(column) to find the failed requests. Could you help me what is missing here? Failed requests count graph is correct. [OR should I consider the column with zeros for failed requests count? seems that is matching]

See what I am seeing TP and Failed requests count.


Go back to my Step #2 and make sure you UNCHECKED the "Share Axis..." option. This will allow each Y axis to autoadjust.

Thanks @Joseph M. H. I totally missed it. after unchecking that box, I can see the y-axis updated with the correct range. Thanks, Suresh.