cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Appmon server & frontend server faill to start (processes not responding)

ynias_reynders2
Contributor

Both servers faill to launch and i have a hard time understanding the log files:

frontendserverlauncher-60320.log

serverlauncher-48360.log

11 REPLIES 11

pahofmann
Champion

I'd recommend opening a support ticket for this issue.

peter_karlhuber
Dynatrace Pro
Dynatrace Pro

Do you have the Server.0.0...log files as well? The launcher doesn't appear to get feedback from the jvm processes it starts. Do you have a local firewall enabled that might block ports like 50000?

Here is the log file, but you won't find anything usefull in here. A few hours ago it worked and after stopping the services they can't start again. server00.log

Hmm, yes, strange. The jvm seems to be stuck when trying to shut down the vm.

No code of ours appears to have been loaded at that point except for some agent threads, that's probably why there aren't any logs from the server.

It's possible that the agent itself stalls the starting (depending on how it's configured).

Is there a collector running on this host? If not please try starting it before the servers.

If that doesn't help, please attach as a zip file the whole log folder of the dynatrace installation and the .ini files that are being used to start it up. If you have the option of opening a support ticket, that might be more efficient in this case.

Can't open a support ticket cause this is our test enviroment that has no internet connection and also it's prohibited from my company to send config files. Still thanks for the help though

stefan_moschins
Dynatrace Guide
Dynatrace Guide

From the log it looks like an OSGi related issue:

2018-01-25 09:32:58 [00000104] warning [java  ] "Framework Event Dispatcher" #17 daemon prio=5 os_prio=0 tid=0x0000000017975000 nid=0x10bc in Object.wait() [0x000000001b43e000]
2018-01-25 09:32:58 [00000104] warning [java ] java.lang.Thread.State: WAITING (on object monitor)
2018-01-25 09:32:58 [00000104] warning [java ] at java.lang.Object.wait(Native Method)
2018-01-25 09:32:58 [00000104] warning [java ] at java.lang.Object.wait(Object.java:502)
2018-01-25 09:32:58 [00000104] warning [java ] at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.getNextEvent(EventManager.java:400)
2018-01-25 09:32:58 [00000104] warning [java ] - locked <0x0000000733894598> (a org.eclipse.osgi.framework.eventmgr.EventManager$EventThread)
2018-01-25 09:32:58 [00000104] warning [java ] at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:336)
2018-01-25 09:32:58 [00000104] warning [java ]
2018-01-25 09:32:58 [00000104] warning [java ] Locked ownable synchronizers:
2018-01-25 09:32:58 [00000104] warning [java ] - None

Can you please attach the OSGi log as well, the file path is <DT_INSTALL_DIR>/server/osgi.eclipse/<TIMESTAMP>.log (e.g., /server/osgi.eclipse/1516357203425.log).

Here you go, but the path is a bit different for me(C:\Program Files\dynaTrace\Dynatrace 6.5\server\osgi):

1516953641288.log

stefan_moschins
Dynatrace Guide
Dynatrace Guide

Looks indeed like an OSGi issue, I think someone copied some 7.0 bundles to the 6.5 installation: org.osgi.framework.BundleException: The bundle "com.dynatrace.diagnostics.serverbootstrap_7.0.0.2455 [8]" could not be resolved.
I suggest a fresh install of 6.5 or 7.0.

ynias_reynders2
Contributor

Okay, I just reïnstalled appmon and that did it for me. For some reason the folder structure of OSGI was really messed up, so it couln't find anything?

Yep, perhaps, you've tried to install the 7.0 version into the old 6.5 folder?

I don't think so, It had a dynatrace 7.0but it was on there for like 4 months, and both versions worked fine then