cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bad Request - Invalid Verb

saanjeith_varat
Inactive

Hey Guys,

Has anyone ever seen this issue before? There was a code change put in and there was an external issue revolving around enabling ports for those individuals who use VPN with the application. The question is if the issue below was a cause or effect of Dynatrace UEM? Cheers,

Sanj 

4 REPLIES 4

dave_mauney
Dynatrace Champion
Dynatrace Champion

I suggest using Fiddler to "remove" the dtagent from the response to your web browser to test if the dtagent code is causing the problem.

Here is how I manipulate it when I do this sort of thing:

Use Fiddler2/Rules/Customize Rules and add code similar to the code below at the end of the "static function OnBeforeResponse(oSession: Session)" method:

 

//Turn off DT AGENT for testing

oSession.utilDecodeResponse();

oSession.utilReplaceInResponse('dtagent','dtXXXXX');

 

//Manipulate DT AGENT settings for testing

//oSession.utilDecodeResponse();

//oSession.utilReplaceInResponse('reportUrl=/','reportUrl=http://www.example.com/');

//oSession.utilReplaceInResponse('/dynaTraceMonitor','/dynaTraceMonitor|domain=.example.com|cors=true');

 

If renaming it "dtXXXXX" doesn't "fix" it, try replacing the entire line with null also...

HTH,

dave

 

Thanks for the response David, I will see if this is a possibility at my client site.

Cheers,

Sanj 

andreas_grabner
Dynatrace Leader
Dynatrace Leader

The error says "Invalid Verb". Verb refers to GET, POST, PUT, DELETE, ... - not sure if that has to do with dynaTrace UEM.

The only thing I can think of is that the monitor signal we send back is by default sent to /dynaTraceMonitor as an HTTP POST. If the Web Server is configured to not allow HTTP POSTs on that default URL you may see this result. Thats why we allow you to configure a different URL for the monitor signal, .e.g: /resources/monitor/dynaTraceMonitor. You can change the URL to a URL that is configured on the web server to allow HTTP POSTs

Andi

Thank you for the response Andreas!

Cheers,

Sanj