cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Bootstrap agent not loaded

We are publishing to azure cloud

https://github.com/Dynatrace/Dynatrace-Powershell

using the above powershell commands it works fine when its first installed i get the "All agents ok" message , but when I deactivate and activate I get the message saying

"Bootstrap agent(dtagent.dll) is not loaded , but has been activated process restart or sys ..."

This is what I found in the VM Event viewer which dyntrace Agent is installed

Loading profiler failed during CoCreateInstance. Profiler CLSID: '{DA7CFC47-3E35-4C4E-B495-534F93B28683}'. HRESULT: 0x80040154. Process ID (decimal): 3032. Message ID: [0x2504].

5 REPLIES 5

c_schwarzbauer
Dynatrace Champion
Dynatrace Champion

HRESULT 0x80040154 basically means "COM Class not registered".

I'm not very familiar with the powershell scripts, so could you please elaborate what you did exactly when saying "first installed" and "deactivate and activate".

also I assume you saw connected Agents in the AppMon Client at first and no longer afterwards, right?

yes exactly , it connects once a fresh installation is done using the powershell scripts , but if we manually deactivate and reactivate the agents I get that error

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello Sajidh,

I guess the below online performance clinic is for your and can provide you some more knowledge and info on SaaS based solution.

https://www.youtube.com/watch?v=QFRUiPiCuHw&index=...

Regards,

Babar

looks like I have missed this
thank you !

https://github.com/dynatrace/dynatrace-powershell this is the method I am using currently for the cloud deployments ,