cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Changing the name of the collector (not host)?

rene_neubacher
Participant

We are using salt and scripts for installing Collectors,Agents,..

Now I installed a new collector and I added

DT_OPTARGS="-server x.x.x.x" in the init.d script

Now the collector is connected to the server!

How can I also change the Name of the Collector how it appears at the server without changing it in collector/conf/collector.config.xml (where it says DON'T touch this file)?

Additional: is anyone else using SALT/hybris/NGINX?

Thanks in advance!

Rene

5 REPLIES 5

Radu
Dynatrace Pro
Dynatrace Pro

Hi Rene,


Either in the DT_OPTARGS also add "-instance [newNameForCollector]" (also keeping the server flag)
OR in the DT_INSTANCE add the name (e.g. DT_INSTANCE="myNewCollector")


Regards,

Radu

rene_neubacher
Participant

Hi Radu,

I tried both ways, but it's not the same as the name in the config xml.

When I use for example

DT_INSTANCE="NSL
TEST Collector"

OR

DT_OPTARGS="-name NSL TEST Collector"

it is shown as "nsl" in the Name Tab at the server.

It could be a possibility for me using "_" in the instance so that I can use it like this.. but it seems to be not the same..

cause my old migrated Collectors (I changed it in the early days in the config.xml) appear as "APPL TEST Collector" for example and the instance and log files don't have another name.

SO I'm looking just for the name appearal.

Thanks

Radu
Dynatrace Pro
Dynatrace Pro

Hi Rene,

That is the only way I know possible to change the name of a collector - create it as an instance. The default collector is Dynatrace Collector. Every other differently named collector will result in creating its own log file and folder based on the name given to keep the data separated for easier troubleshooting.

I see that you replied "DT_OPTARGS="-name ...."", the flag should be -instance. Is this a typo?
I think to accept spaces we might have to use single quotes too.

Please retry with your parameter changed as: DT_OPTARGS="-instance 'NSL TEST Collector' -server ..." (also keeping details of the server for that flag).

This is the recommended best practice. The config.xml file should not be modified for this purpose.

Regards,

Radu

rene_neubacher
Participant

Hi Radu,

sorry for the typo, of course I used - instance.

In this way:

DT_OPTARGS="-server x.x.x.x -instance 'NSL TEST Collector'"

it is working with the full name!

only little thing is that it is transferred in small letters.. so it appears as "nsl test collector"

thx

Rene

Yes, that is expected behaviour. It is all lower case.