cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Communication between dynatrace collector and server fails

johannes_kleinl
Participant


After updating the jdk on the dynatrace collector we have communication problems between collector and server.


In the dynatrace server log we see:

2017-07-26 15:21:23 SEVERE [CollectorControlChannelCachedSerializers] Found object java.vm.info at cache pos: 109. Cache should NOT contain this value!
2017-07-26 15:21:23 WARNING [PassiveCollectorSessionInitializer] error during session handshake[currentthread=Thread[CollectorCommunication-Released-Oux0209a:43806:Inbound:Plain:LZ4:7fa08f79-5377-4f99-8944-a
20e87f56214-Listener,5,main]]: Found object java.vm.info at cache pos: 109. Cache should NOT contain this value!: Found object java.vm.info at cache pos: 109. Cache should NOT contain this value!
2017-07-26 15:21:23 INFO [DefaultSessionManager] successfully closed session Oux0209a:Plain:LZ4:Collector

and in the collector log we see:

2017-07-26 15:25:02 INFO [Collector] connecting to server at 'vadtd236a1:48682'...2017-07-26 15:25:02 SEVERE [DefaultSessionManager] Communication error: Communication error2017-07-26 15:25:02 WARNING [FastConnectionPool] connection Closed-vadtd236a1:48682:Outbound:Plain:LZ4:1ade2da4-3a8c-4fae-9d9f-07ddd7be4287 was not in pool - unable to remove...2017-07-26 15:25:02 SEVERE [Collector] Communication error: Communication error2017-07-26 15:25:02 INFO [Collector] Server[vadtd236a1:48682] has been disconnected - reconnecting in 15s

Version of the dynatrace collector JVM:

java version "1.8.0"
Java(TM) SE Runtime Environment (build pap6480-20150129_02)
IBM J9 VM (build 2.8, JRE 1.8.0 AIX ppc64-64 Compressed References 20150116_231420 (JIT enabled, AOT enabled)
J9VM - R28_Java8_GA_20150116_2030_B231420
JIT - tr.r14.java_20150109_82886.02
GC - R28_Java8_GA_20150116_2030_B231420_CMPRSS
J9CL - 20150116_231420)
JCL - 20150123_01 based on Oracle jdk8u31-b12

Version of the dynatrace server JVM:

java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

Any idea how to solve the problem?

2 REPLIES 2

Hello Johannes,

This is a case for Dynatrace support to look at. Open a ticket at https://support.dynatrace.com/supportportal/secure...

Regards,

Jacob P.

johannes_kleinl
Participant

We solved the issue by stopping the dynatrace collector and then deleting the collector in the dynatrace client menu "settings" -> "dynatrace server" -> "collector" list