cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Data power plugin not working! No data in dashboard.

rajanikanthanka
Inactive

Hi everyone,

I never worked before with plugins. I was asked to check why the data in dashboard is not shown for Datapower Monitor plugin. I don't know how to get started.Please help me fix this.

Thanks,
Rajani

datapowerplugin.png

37 REPLIES 37

BabarQayyum
Leader

Hello Rajanikanth,

Which Dynatrace APM version do you have?

There are some following known issues:

  • If you upgrade Datapower firmware to 7.2.0.2, you might get the error below from the DataPower Plugin. This is a Java 7 and below issue and our Collectors run in Java 7 for version 6.2.x and most earlier supported versions as well. If you upgrade to 6.3 which uses Java 8 under the covers, this problem should go away.
  • javax.net.ssl.SSLException: java.lang.RuntimeException: Could not generate DH keypair Linked Exception - Caused by: java.security.InvalidAlgorithmParameterException: Prime size must be multiple of 64, and can only range from 512 to 1024 (inclusive).

Check the following link for better understanding:

https://community.dynatrace.com/community/display/...

Regards,

Babar

rajanikanthanka
Inactive

Hi Babar,

2datapowerplugin.png

I think this is the version of my Datapower plugin running on 6.2. My Dynatrace server and client running on 6.3 versions.So you think i should upgrade this to 6.3 version and then problem should be resolved?

Hello Rajanikanth,

According to below statement, it should be resolved:


  • If you upgrade Datapower firmware to 7.2.0.2, you might get the error below from the DataPower Plugin. This is a Java 7 and below issue and our Collectors run in Java 7 for version 6.2.x and most earlier supported versions as well. If you upgrade to 6.3 which uses Java 8 under the covers, this problem should go away.

Regards,

Babar

Oh! I will try to upgrade my datapower plugin to 6.3.
I am looking for data power monitor plugin of 6.3 in APM community but I couldn't find it. Could you please provide some link for this?

Hello Rajanikanth,

"The DP Plugin should now be agnostic to the the DP firmware version. And it has been tested with 6.5. Let us know if you have any trouble."

You can find the above comments in the bottom of the below link:

https://community.dynatrace.com/community/display/DL/WebSphere+DataPower+Monitor+Plugin

Regards,

Babar

Babar could you please be a bit more clear. Sorry, I don't understand that statement what do you mean when you say DP plugin is agnostic?

My dynatrace version is 6.3.

3dp.png

@Babar Q.

I got access for windows collector ,from cmd prompt I gave "java -version" but it didn't display anything does it mean java is mis

sing in my windows collector or it is already present ?

harshal_pujari
Dynatrace Pro
Dynatrace Pro

Hi Rajanikanth,

Does the DataPower plugin log (double clickSystem Information dashlet and search for "Datapower) provide any insight on why it is not working?

If not, In the plugin properties under Settings-->Dynatrace server, you can turn the logging level to Fine and then check the logs.

Please let us know if you are still experiencing the issue.

Regards,

Harshal.

Hi Harshal,

Where can I see data power plugin logs?
I changed log level to fine now but how abt plugin logs?

How do I check this?

You should be able to find the Data Power plugin logs if any in the collector logs or the server logs in the system information dashlet of DT. In the side panel you should see system information -> find the collector that you are running the DP plugin on a search through the collector.0.0.log for any mention of data power. If there is none, you can do the same in the server.0.0.log. If you do not find any entries then it might be a simple permissions issue where the credentials you are using do not have the necessary permissions to access the DP SOMA console. You can check with the DP team to confirm that.

Hi David,

From system information I searched for collector.0.0.log and server.0.0.log from the collector responsible. I searched for data power in both of these log files but I was able to see logs in only collector.0.0.log

I am including those logs here .Please take a look at them.

collector00log.txt

server00log.txt

I don't see any issues in the logs. I would check that the metrics are selected in the DP plugin measure settings. Some of the measures in your first screen shot say removed, did a member of your team change what is being collected or turn off the DP plugin task altogether? In the system profile where you DP plugin runs could you check the tasks and monitors to see the settings for the DP plugin task? Check that every is as you expect in there.

I am not sure if someone changed any plugin tasks. I checked with DP team they said that user is having admin rights and can able to login.
How do I check the tasks and monitors to see the settings for the DP plugin task?

The Tasks and Monitors dashlet is in the same side menu as the system information dashlet. If you open it and search for DataPower you should be able to find the task related to that plugin and then you will be able to see the status: last run successful, incomplete or failed.

Here is some documentation on it: https://community.dynatrace.com/community/display/DOCDT65/Tasks+and+Monitors+Dashlet

David i checked in tasks and monitor i found this info4status.png

The red indicates that it failed the last run and that is why there is currently no data on the dashboard. You can do a few things, try running the test manually by clicking the play button, if that works, then great! If not, hovering over that line should bring up a window with more details as to what the issue was. You can also right click and edit it to make sure the credentials are correct and that you DataPower team didn't recently update them. I would confirm the credentials you are using in the monitor with your DP team.

Manually i runned it by clicking run now. Now all the red buttons turned green but there is no data in the dashboard. I checked with DP team they gave me username and password. I re-checked if the username and password details are all good.
I don't know what is happening with this.

You can watch it over the next few minutes. The dashboard should start to populate with data as the old timeframes are passed. I am not sure what caused it to fail, but since there are no entries in the logs that are useful, this is as far as I can take it. I'm glad the credentials are correct and that it is working now though.

I waited for almost 45minutes to see if any data started coming into dashboard but no luck David. However we raised a ticket for support team but they said they can't provide any support in this datapower plugin case.
I am manually trying to add measures and see if they can take add by rgt click on Name-->edit-->measures-->create measures(adding httpstatus code,cpu usage...) but a getting a error like5.png6.png

You could try copying the monitor in the tasks and monitors window and re-entering the connection credentials and then checking to see if you can chart the metrics from the new monitor. Maybe something got corrupted in the original monitor.

I looked into tasks and monitors into this data power monitor and see no measures are present in that stats for particular hosts.

I tried to creating a new monitor with this plugin, added hosts in in this and all measures specified by default. Its running without failure when scheduled but atlast it is not returning any data in dashboard.

I tried chnaging the username and password of admin by giving a false credentials and still it is not showing error when scheduled to run!

harshal_pujari
Dynatrace Pro
Dynatrace Pro

Hi Rajanikath,

Do you see a file, similar to the one shown in the screenshot below? If yes, can you please upload it?

This file is in the System Information dashlet in the cockpit on the left

datapower-logfile-location.png

Yes Harshal I found a log file with that name. I am attaching it here please check it.\

datapowermonitormonitor00log.txt

harshal_pujari
Dynatrace Pro
Dynatrace Pro

Thanks Rajanikanth. I see only warnings in the logs, no errors as such.

So, from my understanding, the Datapower plugin in green (reading comments above), but there is no data in the dashboard.

Looking at various screenshots, I think the problem is that Datapower plugin runs under the "test" system profile, but your datapower dashboard is pointing to the Service UAT dashboard.

In the Datapower dashboard, click on the Service UAT link at the top and change it to "test". Please let us know now if your dashboard now has data.

Regards,

Harshal.

Harshal we have three system profiles showing Datapower monitor. When I confirmed it with my colleague that Services_UAT is the main sys profile for this. I am including rest of the sys profiles. Please check it.
tasks-and-monitor-profiles.png

Harshal can you pls check this one?monitor-log.txt

Hi Rajanikanth,

When you right click on the DataPower monitor, do you see data for it. In the logfile you uploaded (monitor-log.txt), I see metrics being retrieved successfully.

Can you please confirm?

Sorry Harshal I didn't get that part. Where should I right click on Data power monitor to see if there is any data?

datapower-monitor-working.png

Hi Rajanikanth, please see the screenshot below

DP-Stats-default and dp-dev01

details.png

From the collector machine, can you check if you can either telnet to the datapower device or enter the datapower URL in a browser and get a valid response?

@Harshal P.Sorry for responding lately. I tried to telnet to datapower device from collector and I didn't get any response for it. I also wanted to chek with URL but nobody has idea which to be reached. Our collector(Windows) do not have any java running on it, is it something mandatory to have?

harshal_pujari
Dynatrace Pro
Dynatrace Pro

Hi Rajanikanth,

Yes it is mandatory to have that. From the collector machine, you should be able to get to the Datapower device. That's how the plugin will return data.

Log in to the collector machine and run this URL in the browser:

https://dp-dev01.dteco.com:5550/service/mgmt/curre..

Let me know the results.

Harshal I tried to access this URL from collector in a browser but all I am getting is some error.

In programs I did not see any java installed in collector. I am attaching those images here.

Charles_Miller
Participant

Rajikanth,

Browsers don't always know what to do with an XML response. Either that or the request is returning nothing. Nevertheless, you are better off using a command line tool like curl or wget. Both are freely available.

Below is an example of using curl for CPUUsage metrics, the request/response is shown below. Make sure to do this from the same Collector machine that is running the DP Plugin. A sample response is shown below as well. If you don't get a nice XML response like below, then the plugin will also fail for the same reason. Best to make sure this works properly before digging into what the DP Plugin is doing.

Put the request XML below into a file called soma_getstatus.xml and issue this command ...

curl -k -u user:password -d
@soma_getstatus.xml https://DataPowerIP:Port/service/mgmt/current


Request

<?xml version="1.0"
encoding="UTF-8"?>

<env:Envelope
xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">

<env:Body>

<dp:request
domain="default"

xmlns:dp="http://www.datapower.com/schemas/management">

<dp:get-status class="CPUUsage"/>

</dp:request>

</env:Body>

</env:Envelope>

Response

<env:Envelope
xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">

<env:Body>

<dp:response
xmlns:dp="http://www.datapower.com/schemas/management">

<dp:timestamp>2008-03-19T17:32:17+01:00</dp:timestamp>

<dp:status>

<CPUUsage
xmlns:env="http://www.w3.org/2003/05/soap-envelope">

<tenSeconds>5</tenSeconds>

<oneMinute>3</oneMinute>

<tenMinutes>6</tenMinutes>

<oneHour>6</oneHour>

<oneDay>6</oneDay>

</CPUUsage>

</dp:status>

</dp:response>

</env:Body>

</env:Envelope>

I see I don't have enough permissions to download curl on my collector. This is the link I am using for it.
https://curl.haxx.se/dlwiz/?type=bin&os=Win64&flav=-&ver=*&cpu=x86_64

Once I get access, I will download it on collector and will let you know what I see.

rajanikanthanka
Inactive

can anyone please help me to set up curl on my collector? I downloaded several curl.zip files but none of them has curl.exe file.