cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DataPower Plug-In not returning data

daniel_giovanel
Newcomer

Hello,



Running dynatrace v4.2 and DataPower Plug-in 4.2.0.3154. I set 'system statistics' on for a few domains, including 'default' and 'services_dev'. Getting all correct data for 'default' domain. When I setup a new monitor for domain 'services_dev' it always provides 'null' for most measures including memory. The only measures I get are FirstResponseDelay, HeaderSize, HostReachable, HttpStatusCode, ResponseComleteTime, ResponseSize, Throughput. Using SOMA 'get-stats' operation from the soap-UI I can retrieve the values (for memory, as example) just fine.



This is the only output I see in the DataPower Plug-in log when running the plugin:



2013-05-23 13:07:31 INFO DataPowerMonitor@DP EADPDEV01 - services_dev_0 Executing method: POST, URI: http://eadpdev01:5550/service/mgmt/current, SOAP Envelope: <?xml version="1.0" encoding="UTF-8"?><env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Body><dp:request domain="services_dev" xmlns:dp="http://www.datapower.com/schemas/management"><dp:get-status class="ConnectionsAccepted"/></dp:request></env:Body></env:Envelope>

2013-05-23 13:07:31 WARNING HttpMethodBase@DP EADPDEV01 - services_dev_0 Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.

2013-05-23 13:07:31 WARNING HttpConnection@DP EADPDEV01 - services_dev_0 HttpConnectionManager is null. Connection cannot be released.



I tried different domains other than 'default' and they behave the same way.



Any assistance is appreciated. This would be a great plug-in to monitor domain memory if I can get it to work.



Regards,

Dan

5 REPLIES 5

Jeffrey_Fynboh
Dynatrace Organizer
Dynatrace Organizer

Can you post the contents of the SOAP Request you are performing from SOAP-UI for the 'get-stats' operation on a different domain?

I ran the SOMA “get-stats” operation from soapUI to get the memory statistics. Here is the request I sent:



<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">

<env:Body>

<dp:request domain="services_dev" xmlns:dp="http://www.datapower.com/schemas/management">

<dp:get-status class="MemoryStatus"/>

</dp:request>

</env:Body>

</env:Envelope>



Here’s the response I got back:



<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">

<env:Body>

<dp:response xmlns:dp="http://www.datapower.com/schemas/management">

<dp:timestamp>2013-05-22T09:32:43-04:00</dp:timestamp>

<dp:status>

<MemoryStatus xmlns:env="http://www.w3.org/2003/05/soap-envelope">

<Usage>19</Usage>

<TotalMemory>4194304</TotalMemory>

<UsedMemory>832923</UsedMemory>

<FreeMemory>3361381</FreeMemory>

<ReqMemory>1267920</ReqMemory>

<HoldMemory>434997</HoldMemory>

<ReservedMemory>3999604</ReservedMemory>

<InstalledMemory>8193908</InstalledMemory>

</MemoryStatus>

</dp:status>

</dp:response>

</env:Body>

</env:Envelope>




From within the DynaTrace monitor, here is the string being passed by the DataPower plugin. It returns 'null' values for memory regardless of whether I specify 'MemoryStatus' or leave SOMAMONITORCLASS in.



<?xml version="1.0" encoding="UTF-8"?><env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Body><dp:request domain="services_dev" xmlns:dp="http://www.datapower.com/schemas/management"><dp:get-status class=""/></dp:request></env:Body></env:Envelope>

daniel_giovanel
Newcomer

Would someone be able to provide an update? Thank you! Dan

daniel_giovanel
Newcomer

I figured out the issue, it was security related - the plug-in is now returning correct info for each domain.  Actually, for some reason, I had to switch from using 'admin' to use a priviledged account.   

kiran_vallala
Newcomer

Hi ,

I am facing similar issues.Response in Dynatrace returns null for most of the metrics.I have tried both admin & PA credentials.Is there something other than the credentials cause the issue ?

Regards,

Kumar