Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace APM windows agent deployment


Hi All,

I have installed DT on windows (C:\dynaTrace ....) and trying to configure agent on JBOSS. My path to goes like this :-


This works perfectly fine,however i can not use EasyTravel agent if DT APM tool is not installed at the default location which is under C:\Program Files\...

Now if Install DT at its default location C:\Program Files\dynaTrace\Dynatrace 6.3 ..... and trying to configure JBOSS agent ...i am not able to start JBOSS server :-

Error occurred during initialization of VM
Could not find agent library C:\Program in absolute path, with error: Can't find dependent libraries
Press any key to continue . . .

Following is my agent mapping under file :-

set "JAVA_OPTS=%JAVA_OPTS% -agentpath:C:\Program Files\dynaTrace\Dynatrace 6.3\agent\lib64\dtagent.dll=name=JBoss_LOCAL_DEBUG,server=XYZ:9998

Is there something that i am missing or is there any guide lines how to correctly write the agent path for windows installation ?


Dynatrace Champion
Dynatrace Champion

Hi Amit,

Personally, I almost always install to the default location and then use symlinks (mklink on windows) if there is a problem with accessing a path containing spaces within the application being monitored.



Also, adding double quotes around the full path+file name in your set would probably work...


If you don;t mind, can you give me an example please ? I have tried the following but still same error :-

set "JAVA_OPTS=%JAVA_OPTS% -agentpath:"C:\Program Files\dynaTrace\Dynatrace 6.3\agent\lib64\dtagent.dll"=name=JBoss_LOCAL_DEBUG,server=XYZ:9998

This should work:

set JAVA_OPTS=%JAVA_OPTS% -agentpath:"C:\Program Files\dynaTrace\Dynatrace 6.3\agent\lib64\dtagent.dll"=name=JBoss_LOCAL_DEBUG,server=XYZ:9998

Only change I made was removing the double quote after the set.

The set looks good when I echo it. JBoss still may not like the path with a space, but it's worth a try...

Thanks Dave. Unfortunately still no luck. Here is the error :-

Calling "C:\Home\tools\Utilities\jboss-eap-6.3\bin\standalone.conf.bat"
Files\dynaTrace\Dynatrace was unexpected at this time.


Dave, this is what i had to do to fix the issue :-

mklink /j c:\dtrace "C:\Program Files\dynaTrace\Dynatrace 6.3"
set JAVA_OPTS=%JAVA_OPTS% -agentpath:"c:\dtrace\agent\lib64\dtagent.dll"