cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Dynatrace AppMon 6.5 agent not updated automatically

rmg
Organizer

Hi all,

I upgraded Dynatrace 6.5 in my non-production environment. Some of the application agent were bootstrapped from 6.2 version, some were installed with 6.5.0.1289 version. While the 6.2 version got bootstrapped, the 6.5.0.1289 were not. My server and collector version is 6.5.24.1006.

Does anyone know what could be wrong?

Thanks,

-Ronald

Agent Details
Status: old collector
Connection State: Connected
Technology: Java
Tech Version: 1.6.0 (IBM Corporation)
Started: 2017-11-05 23:28:59
Connected: true
License: License ok; no UEM volume available
Capture: true
Agent Id: 569be65d
Instrumentation Cache Hits: 51676 Instrumentation Cache Misses: 3026
Extended Agent State:
Agent Version: 6.5.0.1289: The Agent cannot get updated automatically. Consider using the proper agent library.

2 REPLIES 2

JamesKitson
Dynatrace Leader
Dynatrace Leader

Edit - also note that this question should be in the AppMon and UEM Open Q&A forum which as the product you are using (as opposed to Dynatrace which is a separate product).

Hi Ronald - in your agent configuration strings are you using the agent file "libdtagentcore.so"? This tells it to specifically use this agent file. You may need to modify the agent string to instead point to "libdtagent.so" which is the bootstrap agent and is what lets it get and use the updated agent files.

See the below example:

<code>`-agentpath:/opt/dynatrace-7.0/agent/lib64/libdtagent.so=name=Java

From:

https://www.dynatrace.com/support/doc/appmon/insta...

James

rmg
Organizer

Hi James,

Thanks for pointing out. Now I see the issue.

Best Regards,

Ronald