cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace Client 6.x and 7.x constantly crashing on Linux 64bits

jhem
Advisor


This is a recurring problem for me with last few versions of DynaTrace Clienbt 6.x and 7.x. The desktop client keeps crashing, ending up with a core dump of the JVM. I've been trying adjustments to the JVM via dtclient.ini, increasing Xmx to a reasonable 4GB or 6GB, but that doesn't seem to have any effect.


Has anyone else been experiencing this? Feel like asking around before raising the issue to tech support officially.


Below is an example of the last few moments of the client crashing from the console.

2017-09-11 15:38:02 INFO [ServerCommunicationCachedDelegator] Sending system profile "dynaTrace Self-Monitoring" to server; revision: 7811385419706297185 (user); 0 (changeset); last stored change: 2017-09-02 02:03:01; original revision: 7811385419706297185 (user); 0 (changeset); last stored change: 2017-09-02 02:03:01
2017-09-11 15:38:04 INFO [ServerRestartUtils] Created global incident downtime for server restart in cause of FixPack installation.
2017-09-11 15:38:04 INFO [DefaultSessionManager] successfully closed session dynatrace-tst:Encrypted:LZ4:Client
2017-09-11 15:38:09 INFO [ServerConnectionJob] trying to connect to server with: admin@dynatrace-tst.tjpr.net:2021:Encrypted:LZO:Client
2017-09-11 15:39:41 INFO [DefaultSessionManager] successfully created session: dynatrace-tst:Encrypted:LZ4:Client
2017-09-11 15:39:41 INFO [ClientUpdateManagerFactory] Client Update skipped because FixPack wizard is running.
2017-09-11 15:39:41 INFO [ServerCommunicationManagerImpl] The FixPack wizard is running, the check of memory settings is skipped
2017-09-11 15:39:41 INFO [ChartCacheNotifier] received repository state broadcast: CONNECTED - clearing chart caches
2017-09-11 15:39:42 INFO [ServerCommunicationCachedDelegator] System profile "dynaTrace Self-Monitoring" received from server; revision: 1786217926204344172 (user); 0 (changeset); last stored change: 2017-09-11 15:38:02
2017-09-11 15:44:16 [303cb8ad] severe [java ]
2017-09-11 15:44:16 [303cb8ad] severe [java ] ** (:10510): CRITICAL **: atk_object_ref_state_set: assertion 'ATK_IS_OBJECT (accessible)' failed
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:17 [30bca8ad] info [java ] # A fatal error has been detected by the Java Runtime Environment:
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:17 [30bca8ad] info [java ] # SIGSEGV (0xb) at pc=0x00007f549d8077ed, pid=10510, tid=0x00007f54c4828700
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:17 [30bca8ad] info [java ] # JRE version: Java(TM) SE Runtime Environment (8.0_121-b13) (build 1.8.0_121-b13)
2017-09-11 15:44:17 [30bca8ad] info [java ] # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.121-b13 mixed mode linux-amd64 compressed oops)
2017-09-11 15:44:17 [30bca8ad] info [java ] # Problematic frame:
2017-09-11 15:44:17 [30bca8ad] info [java ] # C [libgobject-2.0.so.0+0x347ed] g_type_check_instance_is_fundamentally_a+0xd
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:17 [30bca8ad] info [java ] # Core dump written. Default location: /home/lamento/programas/dynatrace-7.0/client/core or core.10510
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:17 [30bca8ad] info [java ] # An error report file with more information is saved as:
2017-09-11 15:44:17 [30bca8ad] info [java ] # /home/lamento/programas/dynatrace-7.0/client/hs_err_pid10510.log
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:17 [30bca8ad] info [java ] # If you would like to submit a bug report, please visit:
2017-09-11 15:44:17 [30bca8ad] info [java ] # http://bugreport.java.com/bugreport/crash.jsp
2017-09-11 15:44:17 [30bca8ad] info [java ] # The crash happened outside the Java Virtual Machine in native code.
2017-09-11 15:44:17 [30bca8ad] info [java ] # See problematic frame for where to report the bug.
2017-09-11 15:44:17 [30bca8ad] info [java ] #
2017-09-11 15:44:36 [318c68ed] info [native] Process 10510 terminated, exitcode: 6
2017-09-11 15:44:36 [318c68ed] severe [native] Process terminated unexpectedly!
2017-09-11 15:44:36 [318c68ed] warning [native] Option 'restartonfailure' not set, thus terminating application
2017-09-11 15:44:36 [318c68ed] info [native] Dynatrace Client terminated


5 REPLIES 5

peter_karlhuber
Dynatrace Pro
Dynatrace Pro

Hi Julio,

it looks like a gtk issue.

Could you please post the file

/home/lamento/programas/dynatrace-7.0/client/hs_err_pid10510.log

? Cheers, Peter

infraaplicacao
Newcomer

Sure! Here it is.

hs-err-pid10510.log

infraaplicacao
Newcomer

I might as well complement the scenario. My desktop is running Linux Mint 18.1 Serena

> lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: Linux Mint 18.1 Serena
Release: 18.1
Codename: serena

It's a distro based on Ubuntu 16.04 LTS, but I'm not sure which versions of GTK it includes.

peter_karlhuber
Dynatrace Pro
Dynatrace Pro

Hmm, seems similar to this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=5009...

Unfortunately there doesn't appear to be a solution. Please open a support ticket referencing this forum discussion. It would be helpful to attach a support archive, the hs_err*.pid and the core file. Cheers,

Peter

infraaplicacao
Newcomer

Got a response from the DynaTrace support team today, so here's a quick update.


The issue really seems to be a compatibility problem with the latest GTK libs, filed as Eclipse bug report 392967. The suggested workaround is to remove the current GTK release and revert to older packages that can be downloaded from the links:


https://packages.ubuntu.com/xenial/amd64/libwebkit...
https://packages.ubuntu.com/xenial/all/libwebkitg...
https://packages.ubuntu.com/xenial/amd64/libwebkit...


Pick any official mirror for download, remove the recent libwebkitgtk-1.0-0 and install all three deb files manually.

wget 'http://mirrors.kernel.org/ubuntu/pool/universe/w/webkitgtk/libwebkitgtk-1.0-0_2.4.10-0ubuntu1_amd64.deb'

wget 'http://mirrors.kernel.org/ubuntu/pool/universe/w/webkitgtk/libwebkitgtk-1.0-common_2.4.10-0ubuntu1_all.deb'

wget 'http://mirrors.kernel.org/ubuntu/pool/universe/w/webkitgtk/libjavascriptcoregtk-1.0-0_2.4.10-0ubuntu1_amd64.deb'

apt-get remove libwebkitgtk-1.0-0

sudo dpkg -i libjavascriptcoregtk-1.0-0_2.4.10-0ubuntu1_amd64.deb libwebkitgtk-1.0-0_2.4.10-0ubuntu1_amd64.deb libwebkitgtk-1.0-common_2.4.10-0ubuntu1_all.deb

Will post back if I see the error again.