cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Easytravel Linux - Supported Distributions

fabiol
Guide

Hi Everyone,

this thread is essentially a follow-up of this one. I was wondering what is the current support for the following mainstream distributions:

  1. CentOS/Red Hat
  2. openSUSE/SUSE
  3. Ubuntu/Mint

Last time I tried the application I was unable to start Apache and Nginx and was wondering if it the issue has now been fixed.

Looking forward to hearing from you.

Regards,

Fabio

9 REPLIES 9

pahofmann
Leader

I have it running fine on CentOS, Ubuntu and Archlinux. Don't know if there are any offical supported distros though, there shouldn't be a general issue running easytravel on any of the mentioned distros.

fabiol
Guide

Hi Patrick,

will definitely give it a go and let you know my findings. And yes, I do not think that there should be any runtime issue as long as Java is installed. The other time I had issues with some configuration files.

P.S. are you using Archlinux in a testing or production environment? That is one distribution I never had the time to check out and was wondering whether it was worth a try or not..

Archlinux is on my local machine / demo environment. I'm using it for my private servers aswell though, it has been the most stable distro for me.

fabiol
Guide

Hi All,

this is just to confirm that AppMon installed seamlessly on:

  • CentOS 7 (6.5)
  • Red Hat Enterprise 7.3 (6.5)
  • openSUSE 42.2 (7.0)
  • SUSE 12 (7.0)

Will get back to you later with details concerning EasyTravel.

Regards,

Fabio

fabiol
Guide

I managed to installed EasyTravel without any problem on openSUSE 42.2 but for some reason no agents seem to be available:

I have installed the system profile but still no luck; the agents overview dashboard shows only the host agent. Not too sure if it matters but the application is installed under /opt/easytravel/.

The agents are installed on the easyTravel System? Which file did you use to start easyTravel?

fabiol
Guide

I performed a full install and I assume that all agents are already on the system (feel free to correct me because I am still new to Dynatrace).

The file I use to start the application is runEasyTravel.sh

My installation directories are:


  1. /opt/dynatrace/ for AppMon
  2. /opt/easytravel/ for EasyTravel

fabiol
Guide

Hello everyone,

I would like to follow this up.

I am facing the same problem on a different operating system (CentOS 7), where Apache is also displaying the error "Startup Timeout". In this case I am using EasyTravel 7.

Looking forward to hearing from you.

Regards,

Fabio

Hi Fabio

I had the same error message and after trying to start httpd manually copied the resulting error message into google and found that I was missing the glibc.i686 library. After installing that, everything ran fine. I think this is a library allowing 32 bit applications to run on 64bit linux.

Regards

Gregor