cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Easytravel Ubuntu Server - AppMon 6.5 - Nginx and Apache not starting

fabiol
Guide

timeout-apache.pngtimeout-nginx.pngHello everyone,

AppMon seems to be working seamlessly in my testing environment, but the same cannot be said for EasyTravel.


I even tried to explicitly making the files executable (chmod +x) but still no luck. I am wondering if anyone else has come across a similar scenario.

P.S. I know, on Windows up and running in a few minutes. However, I would really like to test the environment on Linux as well.

5 REPLIES 5

pahofmann
Champion

Could you add more information on why the processes are failing? You can right click on the failed process to view the log file, or grab it from the machine itself/easytravel output.

fabiol
Guide

Hi Patrick,

when I click on "show error.log" nothing happens, therefore I attached a screenshot of the process running in the terminal and throwing a recurring exception.

For Apache I am wondering if this could be related by ports already in use (on Windows port 443 is used by VMware and Skype) but cannot see any of the defaults already in use here.

As far as Nginx is concerned I am honestly not too sure, as I am not familiar with it.

Unfortunatley the screenshots do not really help, the exception is caused by the apache/nginx not being there. We need to look at the apache log to see why it isn't starting.

If you can't open it in the easyTravel config interface just do it on the machine itself. In the home folder of the user you start easytravel with there should be a .dynaTrace folder with a log folder inside. There you can find the apache error.log

fabiol
Guide

Hi Patrick,

I have just checked the folder you mentioned but unfortunately there are no logs other than AppMon's.

I tried to start Apache's executable from its folder (how I would on Windows when it does not start) and it failed (see screenshot). In this case not even the process is able to start.

I am wondering if this is related to environment variables?

process-failed.png

fabiol
Guide

Good afternoon everybody,

I installed a standalone version of Apache to exclude environment issues. You can see it running fine in the top left terminal.

I just discovered that some Apache configuration files define Windows paths rather than Linux ones (see top right terminal).

I thought that changing the Server Root would have been enough but might have to go over all the other files as well (see bottom left terminal).

apache-files.png