cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error message : "Bootstrap agent (dtagent.dll) is not loaded, but has been activated" for .net agent configuration

ruchitat
Inactive

We have uninstall dynatrace .net agent(Version 6.3) and re-install dynatrace .net agent(Version 6.5) on .net application server.
But after multiple times restarting IIS services & rebooting server we are getting this error message : Bootstrap agent (dtagent.dll) is not loaded, but has been activated. Process restart or system reboot is required.


In process explore unable to find application process(w3wp.exe) loads dynatrace dll files - dtagent.dll or dtagentcore.dll


Kindly help to resolve the issue.


5 REPLIES 5

Hi,

Did you restart the IIS server?

After that you need have to exercise some traffic to that process for the agent to load. Sometimes you can ignore the error message on the .Net Utility

Radek


ruchitat
Inactive

Hi Radosław J.,

Application server reboot & IIS restart has been done multiple time. There is continuous flow of requests from application side. But still application process unable to load dtagent.dll or dtagentcore.dll and in agent overview we are unable to see agent connected.

Thanks,

Ruchita.


Share agent logs with us, or if you can't check them.


Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

I would explore a permission issue. Perhaps there are some useful messages in the system event log that would point you in the right direction.


Please share agent logs if it possible like @sebastian k. wrote.

Radek