cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error while upgrading from Dynatrace 6.2 to 7.0 version.

nikhil_khaladka
Newcomer

We are getting below
error while upgrading Dynatrace 6.2 to Dyatrace 7.0. We already have Dynatrace
6.2 version running on Windows 2008 R2 Standarad Edition with Service pack 1
machine.Downloaded the installers from "https://downloads.dynatrace.com/downloads/download.aspx?p=1&r=183" link.

All the system requirements and prerequisites are in place.

Error while installing dynatrace-full-7.0.0.2469-x86-64.msi package.

dynatrace-log.txt

Can anyone please help on this issue?

6 REPLIES 6

JamesKitson
Dynatrace Leader
Dynatrace Leader

I see at least one case where this error was resolved by re-downloading the installer - it's possible the download just gets corrupted. If you haven't I would try that again first.

James

nikhil_khaladka
Newcomer

@James K. I did reinstall the packages twice and tried the up-gradation. But no luck. Any specific reason for the download files to be corrupted? Should I take any extra precautions while downloading or installing?

No, that was just a guess based on past experience. If downloading it even a second time doesn't work I would rule that out as the cause. I found some instances where it tries to use a jar unpacker that isn't working and the following was recommended. If this doesn't work I wouldn't want to suggest some of the other fixes I see so I would either wait for some more input here or open a support case:

"Please add C:/windows/system32 to the front of your PATH environment variable and run the installer again. This is usually an issue with the executable using another jar unpacker (unpack200.exe) from another application in the PATH which is not working properly. The new line in the PATH should ensure to use windows native executable."

The above is from a case that had the same installation status code of 1603.

@Nikhil K. you can check the file dynatrace-full-7.0.0.2469-x86-64.msi by using for instance this MD5 calculator:

https://www.microsoft.com/en-us/download/details.aspx?id=11533

and compare it with the one from the download page:

https://downloads.dynatrace.com/downloads/download.aspx?p=1&r=183

It should be 3c0403f605db820fa7636a3b91f2bf05

If it is different, you need to re-download the file. This can happen sometimes for in general for downloads.
If the value matches, the file is downloaded correctly and there is another problem - in that case for instance try to restart the machine.

Regards,

Thomas

nikhil_khaladka
Newcomer

@Thomas K. Thanks for the reply.

We did the md5checksum and it does matches the checksum value that you have mentioned.

"3c0403f605db820fa7636a3b91f2bf05"

md5checksum.jpg

Also tried the restarting of Machine option. But still encountered with same issue.

Do you have any more suggestions or guidelines to make it work.

I would try James' suggestion next: https://answers.dynatrace.com/comments/182438/view.html
If that does not help, please open a support ticket with the information and files currently available here.