Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Frontend Server connecting error


After changing the Java-agents (modification on JVM-setting of JBoss), wanted to restart the Dynatrace services. After that DT is not available anymore.

We have:

- Dynatrace version

- Windows 2008 R2 as a virtual-machine (VMWare).

- All services are running: dynatrace Collector, dynatrace Frontend Server, dynatrace Memory Analysis Server, dynatrace Server, dynatrace Web Server Agent.

If we want to connect with Dynatrace Client, then we are getting the message: "Settings seem to be erroneous, the connection test failed. Please ensure that the Frontend Server has been started. IOException: Unable to connect to localhost:2021 because of the following exceptions: Unable to connect to localhost:2021, Unable to connect to localhost:2021 because of: ConnectException: Connection refused: connect".

The server.config.xml has the entries:

<client clientaddress="" requiressl="true" clientsslport="2021" clientssladdress="" clientallowsavecredentials="true" clientport="2020" /> <frontend frontendport="2030" frontendrequiressl="true" frontendaddress="localhost" frontendsslport="2031" />

The FrontendServer.log contains 2 interesting lines:

2017-04-20 11:54:18 WARNING [DefaultSocketHandlerRunnable] closing connection (reason: 'error while reading first byte from socket - error: SocketException, Connection reset') Fetched-:2031:Inbound:Encrypted:Uncompressed:989e7445-3789-4e4c-8f86-89c01c8ee487 belonging to session :Encrypted:Uncompressed:FrontendLink (Connected). Connection has been lost in Thread: FrontendLinkCommunication-Released-:2031:Inbound:Encrypted:Uncompressed:989e7445-3789-4e4c-8f86-89c01c8ee487-Listener, Exception: class Connection reset

2017-04-20 11:55:13 SEVERE [FrontendServer] Unhandled broadcast message.(The frontend server is still booting, so this may be ok.) Broadcast-type: 114, Class: class

The Server.log contains some more:

2017-04-20 11:54:42 WARNING [DefaultSocketHandlerRunnable] closing connection (reason: 'socket reached end of stream') Released-PSC-DYNATRACE:58798:Inbound:Plain:Uncompressed:20e2be47-70de-4bd5-91b5-3dec7618575e. Connection has been lost in Thread: CollectorCommunication-Released-PSC-DYNATRACE:58798:Inbound:Plain:Uncompressed:20e2be47-70de-4bd5-91b5-3dec7618575e-Listener

2017-04-20 11:55:04 WARNING [CachingFqdnResolver] Failed to resolve DNS for IP '' - had following exception: Cannot resolve FQDN for IP address '' [log message will be suppressed for 30 minutes]

2017-04-20 11:55:04 WARNING [CachingFqdnResolver] Failed to resolve DNS for IP '' - had following exception: Cannot resolve FQDN for IP address '' [log message will be suppressed for 30 minutes]

The Windows has been updated with the last fixpacks, and rebooted. It was not helpful.

Netstat in command-prompt shows that there is no listening on 2021 port from dt-server.

How can it be fixed?

What is the problem?

Would be a totally reinstall of dynatrace helpful?

Please advise! Thanks in advance!


DynaMight Leader
DynaMight Leader

Hello Krisztian,

I read the following solution in the past, so you can also try to fix this problem that the host file contained reference to localhost to an IP address, therefore, removing the localhost from the IP reference allow the communication to work correctly between frontend and backend. You do the modification in the host file and then restart the frontend server service, if it doesn't work then you can restart the host itself.




Thanks Babar,

We have tried, but it did not helped. The base of the issue is that the server has no "listening" on 2021 port. It is a "strange thing".

Any idea?

Regards, Krisztian

Hello Krisztian,

Try the Java WebStart Client with the following different methods.

The Java Webstart Client requires a JRE >= 1.8.0_45.

https://<servername>:8021 or 8020 (non-SSL)

Once you will be successfully logged in then go to the Settings > Dynatrace Server > Services and check the listening port.




kindly check 3 things

1. Check your fire wall connection. which has to be off. e.g, chkconfig --list | grep iptables or service iptables status to check firewall in case of linux environment.

2. restart the DT server if possible and start and stop dtserver services.

3. remove DT server from DT client server settings and press apply if you already added that server and facing that error.

4. refresh / reopen DT Client and add that server again. and test the connection.

for my case same error has been observed and by doing this the problem is fixed now...

hope it will help you out....!!! @Krisztian K.


Hello Krisztian,

We also faced this kind of error from Frontend. Are you using LDAP for login or using Manually Created User ID? In our case we had few issues where we applied fixpack/migrated and our users were not able to login and getting same error. We tried with above option but nothing worked.

So when checked we found that either we need to manually update the User ID and password or update it with LDAP.

May be this helps.



The problem has issued because the database (perm.warehouse) was not available suddenly, caused by a network-blocking, caused by a datacenter-move.

The solution is to stop the server, deactivate the database in configuration-file, include the access from dynatrace-host to database, and restart the server.

The incident is covered by the SUPDT-32956 ticket.

Best regards,




We are seeing similar Warning errors, and would be trying the above listed suggestions.

Note - We currently have license expired error but that's highly unlikely since these warning errors are dated for months.

Also, we haven't configured PWH for this environment, this is DT AppMon 7.x on AWS environment.

2018-07-30 13:22:21 INFO [DefaultSessionManager] successfully created session: :Encrypted:Uncompressed:ClientViaFrontend
2018-07-30 13:22:23 WARNING [FrontendServerForwardingClientRequestListener] Skipping request 6000 as handshake of target-session 'TTX0109ALKVTFSK:Encrypted:LZ4:Client' is not yet complete, session state is Connected
2018-07-30 13:22:23 WARNING [DefaultSocketHandlerRunnable] closing connection (reason: 'socket reached end of stream') Fetched-:2031:Inbound:Encrypted:Uncompressed:a0007fb1-51d1-49fe-a367-bd04d16407f0 belonging to session :Encrypted:Uncompressed:ClientViaFrontend (Connected). Connection has been lost in Thread:

2018-07-30 12:27:39 WARNING [DefaultSocketHandlerRunnable] closing connection (reason: 'socket reached end of stream') Fetched-TTX0109ALKVTFRB:65530:Inbound:Encrypted:LZ4:3135e2ee-da7f-4ee4-ac8b-cfa27342c258. Connection has been lost in Thread: ClientCommunication-Released-TTX0109ALKVTFRB:65530:Inbound:Encrypted:LZ4:3135e2ee-da7f-4ee4-ac8b-cfa27342c258-Listener: com.dynatrace.diagnostics.communication.tcp.connection.SocketConnection logConnectionWillBeClosedMessage:316 Read timed out

2018-07-29 13:35:33 WARNING [DefaultSocketListener] closing connection (reason: 'error while handling request on connection') Fetched-WTX0109ALDITAEF:51440:Inbound:Encrypted:LZ4:edb7d0da-cd30-401c-87ad-3c0f7568af4b belonging to session WTX0109ALDITAEF:Encrypted:LZ4:Client (Connected). Connection has been lost in Thread: ClientCommunication-Released-WTX0109ALDITAEF:51440:Inbound:Encrypted:LZ4:edb7d0da-cd30-401c-87ad-3c0f7568af4b-Listener: com.dynatrace.diagnostics.communication.tcp.connection.SocketConnection logConnectionWillBeClosedMessage:316

Thanks & Regards,



I'm facing a similar issue. When I installed Dynatrace for first time(basic installation), collector was connected to server. And now all of a sudden, even my client is not getting connected to server. Collector, Server and Client are all in one machine. Plz help. Also which all files to add agent path. Eg collector.ini, server.ini etc.