cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Generic Execution Plugin Error calling web service

cwentwo1
Inactive

I am trying to use the Generic Execution Plugin to send events to Service Now. The WSDL for the service now event table requires user authentication so I have entered the user id and password as well as selected Basic. I can get to the WSDL just fine when I run it in a browser from my local machine, but when coming from the plugin I am getting this error:

gepluginerror.jpg

I've tried removing the proxy port thinking this might be the issue, but the plugin must require something there because it puts it right back in.

Has anyone had luck in getting the plugin to work sending events to Service Now via Soap Request?

Thank you,

Cathy Wentworth


2 REPLIES 2

JamesKitson
Dynatrace Leader
Dynatrace Leader

I can say that that error showed for us when the location the plugin was running from did not have access to the wsdl without configuring the plugin. After entering in the correct proxy information it was able to work successfully.

The proxy port configuration isn't used for anything if you haven't selected to use a proxy but I bet you do need to be using a proxy. Your pc might be able to access it because the proxy is already configured. Really there are any number of reasons wherever the plugin is executing from might not have access to that but the proxy is the most likely.

Regardless, based on that error I'm sure your request is not actually reaching the endpoint you're trying to hit. We set ours with a different ticketing system but that is irrelevant at this point until you start getting errors back from the service.

James


cwentwo1
Inactive

Thank you for responding so quickly James. Our internal Service Now team said they didn't think proxy information was necessary, but it sounds like it likely is. I will look into the proxy information to see if there is something we should be entering.