cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Generic Execution plugin Encountered Error When I using SSH

ymaaa
Organizer

I'm using Generic Execution Plugin to execute a remote script on a linux server. I got the following error.

SEVERE [GenericExecutor@com.dynatrace.diagnostics.plugin.extendedexecutor.GenericExecutionPlugin.action] setup method: password authentication method not supported by server '<LXV****>'
2018-06-01 23:27:32 FINER [GenericExecutor@com.dynatrace.diagnostics.plugin.extendedexecutor.GenericExecutionPlugin.action] Entering getExceptionAsString method
2018-06-01 23:27:32 FINER [GenericExecutor@com.dynatrace.diagnostics.plugin.extendedexecutor.GenericExecutionPlugin.action] Entering getStackTraceAsString method
2018-06-01 23:27:32 SEVERE [GenericExecutor@com.dynatrace.diagnostics.plugin.extendedexecutor.GenericExecutionPlugin.action] setup method: password authentication: IOException, stacktrace is 'java.io.IOException exception occurred. Message = 'setup method: password authentication method not supported by server 'LXV5029''; Stacktrace is '''
2018-06-01 23:27:32 FINER [GenericExecutor@com.dynatrace.diagnostics.plugin.extendedexecutor.GenericExecutionPlugin.action] Entering getExceptionAsString method

I'm using exactly same configuration on my testing environment and run successfully. It just don't work on my production. I can use putty to ssh to that Linux server from my dynatrace server.

Is anyone has experience regard this issue? For example what else I need pay attention on Linux or Windows system level.

Thanks

YC

0 REPLIES 0