cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Getting ​FrameworkEvent ERROR in couple of collectors after we upgraded our Appmon to 6.5.6.

kyakkala
Inactive

Getting FrameworkEvent ERROR in couple of collectors after we upgraded our Appmon to 6.5.6.

The collectors are not getting started.
Any idea on a quick fix?

eclipse.buildId=unknown
java.version=1.8.0_102
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
!ENTRY Bootstrap 1 0 2016-12-15 16:55:22.067
!MESSAGE Set property 'org.osgi.framework.os.name' to 'win32' - read OS name was 'Windows Server 2008 R2'
!ENTRY Bootstrap 1 0 2016-12-15 16:55:22.067
!MESSAGE Starting bootstrap hooking, root path: 'D:\Program Files\dynaTrace\Dynatrace 6.5\collector'; upgrades path: 'D:\Program Files\dynaTrace\Dynatrace 6.5\collector\upgrades'; fixpack path: 'D:\Program Files\dynaTrace\Dynatrace 6.5\collector\instances\pmnams2294_cdn\updates'; .ini file: 'D:\Program Files\dynaTrace\Dynatrace 6.5\dtcollector.ini'
!ENTRY org.eclipse.osgi 4 0 2016-12-15 16:55:22.316
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of bundle org.eclipse.osgi.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
Caused by: java.lang.NullPointerException
at com.dynatrace.diagnostics.bootstrap.hook.BundleStartCustomizer.a(SourceFile:46)
at com.dynatrace.diagnostics.bootstrap.hook.BundleStartCustomizer.<init>(SourceFile:39)
at com.dynatrace.diagnostics.bootstrap.hook.AbstractUpdateInfo.installBundles(SourceFile:170)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.b(SourceFile:118)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.a(SourceFile:107)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.a(SourceFile:43)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapHook.g(SourceFile:187)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapHook.frameworkStart(SourceFile:177)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
... 13 more
Root exception:
java.lang.NullPointerException
at com.dynatrace.diagnostics.bootstrap.hook.BundleStartCustomizer.a(SourceFile:46)
at com.dynatrace.diagnostics.bootstrap.hook.BundleStartCustomizer.<init>(SourceFile:39)
at com.dynatrace.diagnostics.bootstrap.hook.AbstractUpdateInfo.installBundles(SourceFile:170)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.b(SourceFile:118)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.a(SourceFile:107)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.a(SourceFile:43)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapHook.g(SourceFile:187)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapHook.frameworkStart(SourceFile:177)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
!ENTRY org.eclipse.osgi 4 0 2016-12-15 16:55:22.316
!MESSAGE Startup error
!STACK 1
java.lang.RuntimeException: Exception in org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of bundle org.eclipse.osgi.
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:233)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:655)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:273)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
Caused by: org.osgi.framework.BundleException: Exception in org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of bundle org.eclipse.osgi.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
... 11 more
Caused by: java.lang.NullPointerException
at com.dynatrace.diagnostics.bootstrap.hook.BundleStartCustomizer.a(SourceFile:46)
at com.dynatrace.diagnostics.bootstrap.hook.BundleStartCustomizer.<init>(SourceFile:39)
at com.dynatrace.diagnostics.bootstrap.hook.AbstractUpdateInfo.installBundles(SourceFile:170)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.b(SourceFile:118)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.a(SourceFile:107)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapBundleLoader.a(SourceFile:43)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapHook.g(SourceFile:187)
at com.dynatrace.diagnostics.bootstrap.hook.BootstrapHook.frameworkStart(SourceFile:177)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
... 13 more

9 REPLIES 9

kisu_pyo
Participant

Fill in the details...

kyakkala
Inactive

What other details you need. Seems only couple of collectors on the server are not upgraded after we pushed 6.5.6 to the server. 4 other collectors on the same server are upgraded properly and are working fine.

Hi Kiran. I would open a support ticket to let our colleagues check this out. This might be a known issue that they can easily address with you

kyakkala
Inactive

The issue is the dtcollector.ini is blank after the upgrade. Updated it and the collector started working fine.

Thanks for the update. Strange that it turned out blank. any thoughts why?

kyakkala
Inactive

Trying to find the root cause with the help of Dynatrace Support.. Not sure why it is blank after the Dynatrace Upgrade. Maybe a bug.

Hey Kiran. If you have any feedback from the support ticket to share let us know. this will help others that may run into the same issue

Thanks

Support didn't find any valid reason why this issue happened. But, something should have corrupted the dtcollector.ini due to which it was blank.

I just had the same thing happen this morning and only on one collector host.