cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Hot Sensor Placement available

rguerrero
Inactive

Good afternoon.

I have seen many cases about hot sensor placement in the forum but in this case it is a very punctual question.

In the agent list "Agents overview" my JVM agent is always displayed in the column "Connect State" with the following value: Connected (Hot Sensor Placement available) even after having applied the option of "Hot sensor placement" continues with the same description.

.....

2017-04-12 05:15:46 [000003ec] info [native] Hot sensor placement request for 0 class(es) (0 KiB) took 0ms.
2017-04-12 05:15:46 [000003ec] info [native] redefineClasses took 0ms.
2017-04-12 05:15:46 [000003ec] info [native] 0 error(s) occurred, 0/0 class(es) redefined in 0 step(s).

....

Why this option is still available?

Thanks for your help.

Regards.

- Roberto

3 REPLIES 3

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello Roberto,

You see this option only for the Oracle JVM but not for the IBM JVM which indicates us that hot sensor is available for those agents always.

Regards,

Baba

Mike_L
Dynatrace Pro
Dynatrace Pro

Hello Roberto,

Hot sensor placement is something that you can execute when you've done changes to your sensors/ (or changed the priority or placement of sensor packs).

The reason why it's saying that you changed 0 classes is because you didn't do any changes to the sensors so the JVM doesn't need to redo any class loading. The text still stays because you're able to do hot sensor placements. Not all JVM's support it.

For more info, see the documentation:

https://community.dynatrace.com/community/display/...

Mike

rguerrero
Inactive

Hello Babar/Michael:

Thank you very much for your answers.

Then indicates us that hot sensor is available for those agents always.

Regards,

Roberto