cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How can I generate large Excel/CSV reports from dasboards and dashlets?

jhem
Advisor

Greetings

I am trying to export a report of all transactions filtered by the PurePath dashlet. The filter selected a total of over 14k transactions.

However, the report does not display all transactions, showing this message at the end of the transaction list.

Not showing 13951 additional table rows, adjust the limits in the Dashboard or Dashlet properties to show the additional table rows.

I eventually found the Dashboard and Dashlet settings to increase the report limits.

But as I change these defaults to a desired limit, the report ends up empty with the following message. See attached PDF for an example: report-2015-10-01-17-01-25.pdf

One Dashlet was removed because the limit of 5,000 rows in tables overall was reached, had 36,952 table rows in report

Can anyone tell me how to make this work? I need to export a large number of transactions do they can be further processed in Excel or LibreOffice.

8 REPLIES 8

nishant_rama
Advisor

Hi Julio,

Dynatrace server settings have a hard limit set at 5k in the server settings. To be able to override this you have to add this flag to your client:

com.dynatrace.diagnostics.reporting.maxTableRowsint (default = 5000)Limits the number of overall table rows in one report. After the limit is reached, Dashlets are excluded from the report. They are listed at the end of the report.

edit the 5000 to the number you want and restart your client then try printing your report. If you are trying to run a task as a report e.g. daily then you will need to override this by adding this flag on the server and restarting the dynatrace server.

Hope this helps.

Nishant

jhem
Advisor

Hi Nishant

Thanks for the reply.

I already have this configured, as instructed by our local dynatrace tech representative:

~/.dynaTrace/dynaTrace 6.2/dtclient.ini

However, the report still comes out empty with the following message.

One Dashlet was removed because the limit of 5,000 rows in tables overall was reached, had 10,000 table rows in report. 

Even if I alter the report limit in the Dashlet properties (screenshots above), it makes no difference.

To clarify, these are the contents of my dtclient.ini

# WARNING:
# Manual changes in this file, except changes that are related to memory allocation, may cause severe problems and system instability.
# Apply manual changes only if you have explicit instructions from dynaTrace Support.
-basedir
client
-vmargs
-Xmx4096M
-XX:MaxPermSize=128M
-Djava.library.path=plugins
-Dosgi.checkConfiguration=true
-Dosgi.bundles.defaultStartLevel=4
-Declipse.registry.nulltoken=true
-Dosgi.instance.area=@user.home/.dynaTrace/dynaTrace 6.2/
-Dosgi.configuration.area=@user.home/.dynaTrace/dynaTrace 6.2/client/osgi
-Declipse.product=com.dynatrace.diagnostics.client.productId
-Dosgi.splashPath=platform:/base/plugins/com.dynatrace.diagnostics.client.branding, platform:/base/plugins/com.dynatrace.diagnostics.client.branding.jar
-Dosgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.core.jobs@2:start, org.eclipse.equinox.registry@2:start, org.eclipse.core.runtime@2:start, org.eclipse.equinox.app@2:start, org.eclipse.update.configurator@3:start, org.eclipse.equinox.event@start, org.eclipse.equinox.ds@start, org.eclipse.equinox.preferences@start, org.eclipse.core.contenttype@start
-Dorg.osgi.framework.language=en
-Dosgi.framework.extensions=com.dynatrace.diagnostics.bootstrap.hook
-Dosgi.nl=en_US
-Deof=eof
-Duser.timezine=America/Sao_Paulo
-Dcom.dynatrace.diagnostics.reporting.maxTableRows=100000

And I also checked the java process itself to make sure this parameter is being included in the Dynatrace client runtime. This is a dump of ps aux | grep java

jhem  11865 14.8 14.6 7054540 1715196 ?  Sl  17:21  0:41 /home/jhem/dynatrace-6.2/jre/bin/java -Xmx4096M -XX:MaxPermSize=128M -Djava.library.path=plugins -Dosgi.checkConfiguration=true -Dosgi.bundles.defaultStartLevel=4 -Declipse.registry.nulltoken=true -Dosgi.instance.area=@user.home/.dynaTrace/dynaTrace 6.2/ -Dosgi.configuration.area=@user.home/.dynaTrace/dynaTrace 6.2/client/osgi -Declipse.product=com.dynatrace.diagnostics.client.productId -Dosgi.splashPath=platform:/base/plugins/com.dynatrace.diagnostics.client.branding, platform:/base/plugins/com.dynatrace.diagnostics.client.branding.jar -Dosgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.core.jobs@2:start, org.eclipse.equinox.registry@2:start, org.eclipse.core.runtime@2:start, org.eclipse.equinox.app@2:start, org.eclipse.update.configurator@3:start, org.eclipse.equinox.event@start, org.eclipse.equinox.ds@start, org.eclipse.equinox.preferences@start, org.eclipse.core.contenttype@start -Dorg.osgi.framework.language=en -Dosgi.framework.extensions=com.dynatrace.diagnostics.bootstrap.hook -Dosgi.nl=en_US -Deof=eof -Dcom.dynatrace.diagnostics.WatchDogTimeout=0 -Dcom.dynatrace.client.configPath=/home/jhem/.dynaTrace/dynaTrace 6.2 -Dcom.dynatrace.restartCount=0 -Dcom.dynatrace.diagnostics.server.ini=/home/jhem/.dynaTrace/dynaTrace 6.2/dtclient.ini -Dosgi.os=linux -Dosgi.ws=gtk -Dosgi.arch=x86_64 -Dcom.dynatrace.diagnostics.WatchDogPort=50000 -jar /home/jhem/dynatrace-6.2/client/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar -name dtclient -showsplash -launcher /home/jhem/dynatrace-6.2/dtclient -Duser.timezine America/Sao_Paulo -Dcom.dynatrace.diagnostics.reporting.maxTableRows 100000

Even though the limit here is configured to 100k rows, and even though I can see the default 10k PurePaths in the dashlet, they refuse to appear in the report.

nishant_rama
Advisor

Hi Julio,

Try adding that flag to the dtserver.ini file then.

Regards

Nishant

jhem
Advisor

I just checked, and this is also already configured in the dynatrace server at dtserver.ini.

This is the full server command line running at the dynatrace server.

/opt/dynatrace-6.2/jre/bin/java -XX:+UseG1GC -XX:MaxGCPauseMillis=1000 -XX:NewRatio=10 -XX:MaxPermSize=512M -XX:PermSize=512M -XX:+DisableExplicitGC -Djava.endorsed.dirs=lib/endorsed -Djava.awt.headless=true -Dosgi.configuration.area=osgi -Dosgi.checkConfiguration=true -Dosgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.update.configurator@3:start, com.dynatrace.diagnostics.serverbootstrap.jar@4:start, org.eclipse.equinox.event@start, org.eclipse.equinox.ds@start -Declipse.ignoreApp=true -Dosgi.noShutdown=true -Djava.util.logging.manager=com.dynatrace.diagnostics.util.modern.LogManager -Dorg.osgi.framework.language=en -Dosgi.framework.extensions=com.dynatrace.diagnostics.bootstrap.hook -Dosgi.nl=en_US -Dosgi.nl.user=en_US -Duser.country=US -Duser.language=en -DproxyHost -DproxyPort -Dhttp.proxyUser -Dhttp.proxyPassword -Dcom.dynatrace.diagnostics.includePrimaryGroupForLDAPActiveDirectory=false -Dcom.dynatrace.diagnostics.strictLDAPAuthentication=false -Dcom.dynatrace.diagnostics.ldapAuthenticationTimeout=600 -Dcom.dynatrace.diagnostics.completenessTimeout=3600 -Dcom.dynatrace.diagnostics.maximumPurePathAge=7200 -server -XX:+UseCompressedOops -Dcom.dynatrace.diagnostics.reporting.maxTableRows=100000 -Dcom.dynatrace.diagnostics.WatchDogTimeout=180 -Dcom.dynatrace.restartCount=0 -agentpath:/opt/dynatrace-6.2/server/lib/libdtserverhelperagent.so -Dcom.dynatrace.diagnostics.server.ini=/opt/dynatrace-6.2/dtserver.ini -Dosgi.os=linux -Dosgi.ws=gtk -Dosgi.arch=x86_64 -Dcom.dynatrace.diagnostics.memorymodel=xlarge -Xmx14G -Xms14G -Dcom.dynatrace.diagnostics.WatchDogPort=50000 -jar /opt/dynatrace-6.2/server/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar -name dtserver -showsplash -launcher /opt/dynatrace-6.2/dtser

You will find the JVM option included in the middle, somewhere.

-Dcom.dynatrace.diagnostics.reporting.maxTableRows=100000

The server has been restarted, and we still get the same result.

nishant_rama
Advisor

Hi Julio,

After you restart and open a dashboard are you changing the config to report 100000 rows? Also bear in mind what version of excel your using older versions maxed out at 65k rows. If all of this is fine then I would suggest opening a support ticket as that should be working.

Regards

Nishant

For anyone interested, I've created an issue in the support group. You can follow it up herehttps://support.dynatrace.com/supportportal/browse/SUPDT-13541

Following up.

After some back and forth with the support team, a definitive solution was found. The real problem relates to how dtclient.ini and dtserver.ini are interpreted by the Eclipse Launcher (which is the base framework for the Dynatrace Client).

Long story short, the JVM option needs to be placed BEFORE the line that says

...

-Deof=eof

...

Only parameters passed before this line are used as JVM options.

That's it... easy as pie 🙂

More details at

https://support.dynatrace.com/supportportal/browse...

Thank you all for the help!

jhem
Advisor

Yes, I have restarted both server and client. Reconfigured the PurePath dashlet and dashboard properties to increase the report limit to 100k and still nothing. The report should at least contain the default 10k PurePaths displayed on the client dashlet, right?

I will open a support ticket.

Thank you, again for the help!

Best regards.