cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How do we make agent compatible with page forced to IE10 emulaton mode

ron_fitzpatrick
Participant

We have a legacy application which requires us to force IE emulation mode to IE10 using the following code:

<meta
http-equiv="X-UA-Compatible" content="IE=10" />

When we try and inject the dynatrace agent to the page for EUE we notice the page is forced to Edge mode and functionality on the page ceases to work. We are working with agent version 7.1.01803. Is there a way to modify the User Experience tab on the System Profile so that this system uses an earlier version of the agent (compatible with IE10 or earlier. (or a different solution?)


2 REPLIES 2

Joe_Hoffman
Dynatrace Champion
Dynatrace Champion

Ron, You can inject an earlier version of the browser agent, although I'm not sure which version of the agent is compatible with IE10. We do not support versions of products which are not supported by their vendors and as I'm sure you know, IE10 was unsupported by Microsoft over 2 years ago.

To inject an earlier version of the UEM agent, edit the profile -> User Experience -> Select an environment if necessary -> Web Applications section. There you will find a pulldown to select alternate versions of the UEM agent. Of course the further back you go, the more risk you incur of other compatibility problems.

Hope this helps.


ron_fitzpatrick
Participant

Thanks for the tip - we'll give it a try. End of the day we need to address our compatibility issue, but this could buy us some time