cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

How do you activate a .NET agent on and EXE when more than one instance of EXE runs at a time ( and capture all instances)

kvarga
Newcomer
 
3 REPLIES 3

andreas_grabner
Dynatrace Guru
Dynatrace Guru

The .NET Agent Configuration Tool allows you to configure WHICH .NET Processes the Dynatrace .NET Agent should actively monitor. If you only specify the .exe name then Dynatrace will automatically monitor ALL instances of that process that match that .exe name.

If you pass some command line options to the .NET Agent Configuration Tool then we only monitor those instances that "contain" that part that you configured on the actual command line. This is a great option to selectively monitor .NET process that match a certain pattern.

In your case it sounds you want to monitor all instances. So - just make sure that you do not provide a command line option in the.net agent config tool and you should be all set

andi

kvarga
Newcomer

Thanks . I'll give this another try. I believe when we did what you suggest, the second+ instances had issues starting up due to the agent startup.

To be clear, I should be able to just configure the EXE name and dynatrace should be able to provide data for all instances of the EXE running concurrently. Correct ?

sooryaprabha_mo
Inactive

Hi Keith,

Using .NET agent, if you want say 4 instances(EXE) running for application in same host. Below are the Steps to be followed.

1)Assuming .NET instances(4 EXE/Process) names already known for configuration.

2)Click on "+" icon at the bottom right corner for configuration 4 .NET process running.

3)Attached the screenshot, it will list the .NET Process running in the server, pick your application .NET Process and configure it.

net-exe-configuration.jpg

4)Then, it will show "All agents are ok" - .NET agent loaded Successfully. (Restart the .NET Process in Services.msc).Also make sure that, in top right corner ->agents should be in Active state.

net-config.jpg

Hope this may help!!

Thanks

Soorya Mohan