cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

How to include agent in Jboss

andrew_knott
Newcomer

Ive looke at the information on your web site, and it doesn't appear very clear to me - but I've tried to append the definition of the agent switches within the standalone.conf.bat file for the JBoss EAP server I want to try the tool with - so the JAVA OPTs statement becomes :

set "JAVA_OPTS=-Xms1G -Xmx1G -XX:MaxPermSize=256M -agentpath:"C:\Program Files\dynaTrace\dynaTrace 6.2\agent\lib64\dtagent.dll"=name=jbossEAP_Monitoring,server=jakdell:9999"

However when I restart the application server it doesn't register with the management station - can you pleae confirm what might be causing this issue and if I've got something wrong please clarify.

I believe standalone.conf.bat is called when I start the app server using standalone.bat - which I also believe should be being invoked when I start the application up from within Eclipse.

CHeers

14 REPLIES 14

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Hi Andy,

I assume you're looking in the Agent Overview dashlet in the dynatrace Client to confirm the dynatrace agent isn't connecting from within JBoss.

If it's not showing up in Agent Overview, then the next thing we want to inspect is the agent log to see if perhaps it's having problem connecting to jakdell, which I assume is where the dynatrace server has been installed. Can you ping jakdell from the machine where you're injecting the agent?

My third thought is whether standalone.conf.bat is really a good place to add the -agenthpath argument. Of course if this file isn't being considered at JVM startup, then of course you'll have to specify the -agentpath argument elsewhere.

Your JAVA_OPTS line looks a bit concerning to me as it appears to have nested " characters. Since you have the dynatrace Agent installed in Program Files (the default), the inner quotes are necesary. Perhaps using some different delimiter, or possibly try moving the ../agent/ directory to a non spaced path, such as c:\dynatrace\ and then your inner quotes wont be necessary.

Hope this helps. Let us know your progress, we're here to help.

joe

andrew_knott
Newcomer

Morning Joe

Doesn't really help me overcome the problem I've got looking at the product right now I'm afraid.

Jakdell is the local mcahine

Yes I agree nested "" can't be good - however I'm going based uon the documentation in the dyunatrace product set - so if this documentation is incorrect then that's not a great start.

I just need to know how to sort this out in the next couple of hours please so I can work out if its wroth lokoing at Dynatrace or going to another product (if I fail at the first hurdle because of incorrect information from the vendor it doesn't inspire me...but hopefully someone can pont me in the right direction.

Just to confirm this has been added to standalone.conf.bat NOT run.conf.bat

Any help will be appreciated

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Sorry for the trouble.

I think the challenge in this situation is either the double quotes or editing the wrong file.

Is there someone you're working with from the sales side?

Can you clarify whether you see any agents in the Agent Overview dashlet?

joe

andrew_knott
Newcomer

Joe

Thanks for the response.

I was talking to someone in your sales team but I solved the problem myself.

We both agreed tha the combination of double quotes didn't seem to be a good idea - so as you suggested I changed the installation path to remove the space and therefore removed the need for the inner quotes - that didn't solve the problem.

I then looked to install the agent on a Linux machine and that went in with no problems.

Went back to investigating the issue on a windows server, and instead of starting up the server from inside eclipse I manually started the server.

At this point the issue was resolved - it iwas because the path to the agent was defined as c:\Program Files\dynatrace\....

The issue here is that it should have been

c:\Progra~1\Dynatrace.....

Making that change the agent started up successfully and registed itself.

This is quite a fundamental constraint that is not identified in the Dynatrace documentation that I've seen which surprises me, and I've suggested that clarification should be included as a matter of some urgency - since c:\Program Files is obviously the default install location for the Dynatrace software.

Cheers

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Andy,

Thanks for pointing out the doc confusion. I will definitely get that team engaged and see about clarifying that page.

harald_berger
Dynatrace Pro
Dynatrace Pro

Hi all,

Sorry for the confusion. Please consider that the documentation applies to production setups only. A startup via eclipse is a development setup and may pass environment variables differently.

I have double checked it with JBoss 7.1.1, Wildfly 8.2.1 and Wildfly 9.0.1. It does work as documented.
For the sake of completeness I did some tests with Wildlfy 8.1.0 and 8.2.0. With these version the documented way does not work when the path contains spaces, no matter how double quotes are used. RedHat changed the startup BAT files in these versions. We were not aware of that and will adapt the documentation, when we have a proper solution.

Please be aware that usage of short path names can lead to problems, as c:\Progra~1\ may refer to different directories on different machines, depending on their creation date.

best
Harry

andrew_knott
Newcomer

so I can categorically state that when I performed a startuip and I put the long name into spec the agent it failed - not sure why yours was working but Im not going to have wasted my tiem with an issue that didn't actually exist.

From my point of view I'm not running the agents on a Windows server, I just needed to understand the core architecture before I look at whether it can meet our needs, in production I'd be running on Linix so this is not an issue for me right now.

Other than to say that the documentation as it stands in the product set is not explicit enough about dealing with double quotes/long Program files path name and I would expect there to be some worked examples of the changes to standalone.conf.bat to be included rather than trying to make people to derive what the configuration file should look like.

harald_berger
Dynatrace Pro
Dynatrace Pro

Hi Andy,

Can you please have a look, which JBoss / WIldfly version you are using?

Thanks

Harry

andrew_knott
Newcomer

It was Jboss 7.1.1on windows 8.1

harald_berger
Dynatrace Pro
Dynatrace Pro

Hi Andy,

Actually your local settings for 8dot3name creation can influence this. Can you please paste the output of following command

fsutil 8dot3name query c:

Thanks

Harry

I almost overlooked there is a second page. Hope this appears on the first one.

guenter_huber
Inactive

Hi Andy,

here is a summary what I (documentation) gleaned from the quick action / stab engineering took on this user problem as consolidated results are in now.

1) I immediately put a word of caution on the documentation page. (JBoss & Wildfly Application Server in Dynatrace 6.2 and 6.1)

The text (without the standalone.bat kludge code) is:

Quote:

Note re nested double quotes on Windows in: set "JAVA_OPTS=...-agentpath:"<pathWithSpace>..."..." Icon:


However unconventional nested double quotes in the instrumentation examples for Windows may appear (set "JAVA_OPTS=...-agentpath:"<pathWithSpace>..."..."), they are correct.

Turns out that the known bug (at least) in JBoss versions 8.1.0 and 8.2.0 prevents usage of spaces in the JAVA_OPTS environment variable.
Solutions:

  • Use the latest version 8 (8.2.1) if possible.
  • If you can install to a space-less path you can get along with 8.1.0 or 8.2.0.
  • As another resort you can apply a special treatment to / edit standalone.bat.

Unquote

I tried to purport the doubts everybody had about the nested quotes.

Feedback is appreciated if there is still something unclear or missing.

2) Engineering say the syntax and path-with-space on Windows is in use at numerous customers. It would be interesting to know what is different on the machine (non-default 8.3 setting?) on that it failed.

Please follow up.

3) Relating to your frustration I still hope that in the end we can say we did pretty well:

  1. Very timely support by real experts on the forum and per mail across time zones
  2. Immediate escalation to engineering when only an ugly kludge helped
  3. Immediate update to the documentation to protect our customers from other people´s bugs. (Glad it wasn´t ours! <g>)

I can personally, honestly say that I never, ever had such an experience from any other company, even when the weight of my company is behind me -- as a potentially big customer.

Thanks for trying us and hoping to see you around!

G.

TLRD;

You ahve to put the JVM argument in server startup.bat or startup.conf.bat with the apparent incorrect double quoting as below:

set "JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=512M -agentpath:"C:\Program Files (x86)\Dynatrace\Dynatrace Agent 7.0\agent\lib64\dtagent.dll"=name=JBossApp,server=10.24.123.123:9998"

Note that Double quotes (4 double quotes) are parsed by JBoss differently.

Regards, Rajesh

Also, It is bad practice to install dynatrace in any directory with spaces.