cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to start Easytravel demo on Linux ?

jocio_morais
Participant

Hi guys,

I have an issue to run Easytravel on ubuntu.

Do you know how can I fix it ?

Regards,

Jócio Morais

jmorais@jmorais-linux:~/Documents/Dynatrace/easytravel/easytravel-2.0.0$ ./runEasyTravel.sh
starting easyTravel
===================

2016-04-09 22:55:17 Launche INFO [Init] -----------------------------------------------------------------------------
2016-04-09 22:55:17 Launche INFO [Init] easyTravel Demo Application - Copyright (C) 2010-2016 dynaTrace software GmbH
2016-04-09 22:55:17 Launche INFO [Init] -----------------------------------------------------------------------------
2016-04-09 22:55:17 Launche INFO [Init] Version: 2.0.0.2173
2016-04-09 22:55:17 Launche INFO [Init] Build Date: null
2016-04-09 22:55:17 Launche INFO [Init] Platform: Linux 4.2.0-27-generic, amd64
Exception in thread "main" java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
at com.dynatrace.easytravel.launcher.SWTSingletonDisplayAdapter.init(SWTSingletonDisplayAdapter.java:33)
at com.dynatrace.easytravel.launcher.Launcher.run(Launcher.java:185)
at com.dynatrace.easytravel.launcher.Launcher.main(Launcher.java:163)
jmorais@jmorais-linux:~/Documents/Dynatrace/easytravel/easytravel-2.0.0$

5 REPLIES 5

dominik_stadler
Dynatrace Pro
Dynatrace Pro

Since AppMon 6.5, the related version of easyTravel is provided as mainly 64-bit binaries, however there are a few leftover places that require some 32-bit libraries, see the step-by-step description available at https://community.dynatrace.com/community/display... for more information.

---------------------------------------------------------------------------------------------------------------

Hi,

it seems you run a 64-bit Ubuntu installation, but easyTravel does not fully support this with the 32-bit binaries that are provided on the community pages.

You can either run easyTravel on an Ubuntu 32-bit installation or use the Web-based launcher via the following commands:

cd weblauncher

./weblauncher.sh

This will provide a web-based view which should provide the same interfaces as the rich-client UI.

Please note that on 64-bit Linux, you likely need to run the following commands to install some additional 32-bit components that are needed by easyTravel:

sudo apt-get update
sudo aptitude install gcc-multilib
sudo apt-get install libxml2:i386
sudo aptitude install lib32z1
sudo apt-get install libcurl3:i386

If you do not get libxml2:i386 you have to enable multilib support first:

sudo dpkg --add-architecture i386
sudo apt-get update

Hi Dominik. Gotcha !!!

You hit in right spot...

Thanks a lot.

Cheers

wilsonmar
Newcomer

So these instructions must be followed if I installed according to http://bit.ly/dteasytravel? If so, can someone add this to install instructions so people are not scratching their heads and searching?


Hello,

I will be Out of the Office until the 2017-04-17 with no email access.

For urgent subjects concerning, please contact Joaquim Gaspar (joaquim.gaspar.atos@edp.pt)



Regards,
Jocio Morais





This email and the documents attached are confidential and intended solely for the addressee; it may also be privileged. If you receive this e-mail in error, please notify the sender immediately and destroy it.




As its integrity cannot be secured on the internet, the Atos group liability cannot be triggered for the message content. Although the sender endeavors to maintain a computer virus-free network, the sender does not warrant that this transmission is virus-free and will not be liable for any damages resulting from any virus transmitted.






Esta mensagem e os ficheiros em anexo podem conter informação confidencial destinada apenas à(s) pessoa(s) mencionada(s) anteriormente e poderão estar protegidos por utilização profissional.




Se não for o destinatário desta mensagem, contacte imediatamente o remetente e apague-a.




Ao não estar assegurada a integridade da mensagem na internet, a Atos não se responsabiliza pelo seu conteúdo. O seu conteúdo não constitui nenhum compromisso para o grupo Atos, salvo comunicação escrita entre as partes.




Apesar do remetente se esforçar por manter a sua rede livre de vírus, não se responsabiliza por quaisquer danos que possam resultar de transmissão de vírus.


Hello Wilson,

You can use the following step-by-step instructions to install the easytravel on linux systems.

https://community.dynatrace.com/community/display/DL/Installing+easyTravel+on+64-bit+linux+systems

Regards,

Babar