cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to upgrade AppMon from 6.3+ or 6.5 to 7.0?

christopher_teb
Organizer

Hi,

I would like to upgrade AppMon from 6.3+ which i use in PRODUCTION to 6.5 or 7.0

Please help with guidelines. waiting.....

Br,

Chris

20 REPLIES 20

BabarQayyum
Leader

Hello Chris,

Use the following link for the checklist to ensure you are ready to migrate.

https://community.dynatrace.com/community/display/...

Regards,

Babar

jan_moeyersons
Contributor

Hmmm... That links to a page for upgrading from 6.3 to 6.5. OP asked about going to 7...

Cheers,

Jantje.

Thanks Jan,

You mean, i have to first upgrade to 6.5 and then to 7.0?

Br,

Chris

Hello Jantje,

Appmon 7.0 is not yet released officially so whenever it will be released then almost the same kind of documentation will be released also for the migration.

Regards,

Babar

OK,fine. I guess we'll have to show just a bit more patience then...

😉 exactly !!!

christopher_teb
Organizer

Thanks all for your quick response,

Actually, i tried to go through that document but its not so clear to me. Please would you in simple terms direct me for the prevention of making a mistake to the PRODUCTION mornitoring. Thats where my fear is!

Chris

Hi Christopher, There will be a Online Webinar for Migration Topic on 5th July. Please look here for more details.

thomas_klambaue
Dynatrace Pro
Dynatrace Pro

Hi Christopher,

Please use the upgrade guide of the version that you are migrating TO, so for 7.0, see the new public EAP documentation:

https://www.dynatrace.com/support/doc/appmon/insta...

Please post specific questions here and I will try to answer them.

The guide is designed with safety first, it is not to fear, it includes backups and is well tested internally, as well as already with EAP customer installations.

You can also contact our sales for enablement services in that regard.

Best regards,

Thomas

Since 7 is major version revision, does there exist any known incompatibilities? Regards, Rajesh.

Hi Rajesh,

see the compatibility page of the upgrade guide for a full statement. In short we achieved to keep collector - server compatibility which previously was not supported across major versions.

The client will not be compatible and not upgradable from existing installs - new install required.

Regards,

Thomas

That's win-win, thanks.

I have a related question: After installing DT 7.0 to our DEV environment, we tried restarting the Collectors through the client interface (Settings > Dynatrace Servers > Collectors > Restart), but they did not pull the new version files from the server (they remained 6.5.10).

When installing the Server, we only put the Server files on the server's host. We did not put the Collector files or Client files on the server's host. Do we need to put the Collector files on the server host before the Collectors (which are on other hosts) can be upgraded? Or is there some other problem we should be looking at?

Only minor version updates will be passed to the Collectors automatically.

For installing AppMon 7.0 on a AppMon 6.X version, you must migrate the Collectors/Memory Analysis Servers/etc too. You can not use the Rich Client to push the major update.

https://www.dynatrace.com/support/doc/appmon/installation/upgrade-and-migration-guide/upgrade-server-collectors-and-clients/

To clarify, "revision"-level updates will be passed down to the Collector. See Versioning scheme for the official naming. So 7.0.1 is passed to a 7.0.0 collector, but not to a 6.5.0 collector.

Regards, Thomas

christopher_teb
Organizer

Hi All,

Was 7.0 released? My Experts, i want to upgrade from 6.3.+ to 7.0. Is it possible?
The reason as to why i want to do so is to have a transaction flow on web dashboards and to extend the limited 16 tiles on web dashboards.

I request by the time am doing an upgrade to have your live support for any mistake could be done since its a PRODUCTION appmon tool.

Br,

Chris

Hello Chris,

For AppMon 6.2 and later, a direct upgrade is possible.

https://www.dynatrace.com/support/doc/appmon/installation/upgrade-and-migration-guide/prepare-to-upgrade/

Regards,

Babar

AppMon 7.0 (May 2017 Release) was made Generally Available on May 31, 2017.

Please open a Support Ticket with Dynatrace in advance so that the team can be aware and ready to assist if any issues arise.

You can make a support ticket here: https://www.dynatrace.com/support/contact-support/

Hi Joshua,

please only open a ticket if you have an actual issue or upgrade guide instructs you to (currently only for very large installations, see there). Otherwise the ticket may be closed as there is nothing useful to do if you don't have a problem yet..

Regards,

Thomas

BabarQayyum
Leader

Hello Chris,

If there is no urgency to upgrade your environment from 6.3 to 7.0 then there is an upcoming performance clinic about 'Deploying, Upgrading and Migrating Dynatrace AppMon' on Wed, Jul 5, 2017 5:00 PM - 6:00 PM AST where you can ask all the relevant questions.

Just register yourself from the following link:

https://attendee.gotowebinar.com/register/87709629...

Regards,

Babar