cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to upgrade the dynatrace/Appmon App in Splunk?

mallempati_sree
Inactive

Hi All,

We are using dynatrace App v2.2.4 in our Splunk environment and planning to upgrade it to v2.4.0. But there is no documentation on how to upgrade Dynatrace App. Can someone help me with the steps of how to upgrade the Appmon/Dynatrace App?

Thanks,

Sree

2 REPLIES 2

mike_villiger
Dynatrace Helper
Dynatrace Helper

You can simply update the application to 2.4.0 from within Splunk. You may need to manually kill the flume process spawned by the previous version of the app as v2.4.0 includes new versions of Flume and the dtFlume.jar which accepts data from AppMon and writes it to the filesystem. The Splunk app is not capable of stopping/killing the flume instance, this will need to be done manually.

kenneth_lynch
Inactive

Sree, after the upgrade, did the alert imports break, with the tag error?