cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I am getting certificate/key bit warnings after upgrading from 6.2 to 6.5 version. details as below:

kbhagat
Contributor

The server certificate is valid from 2008-10-30 to 2018-10-28.
You are currently using the shipped certificates or one with a key with less than 2048 bit for communication and services. A secure setup requires the roll out of your own certificates using Certificate management.

6 REPLIES 6

BabarQayyum
Leader

Hello Kishor,

The current installed certificate is Dynatrace Product Built-in Certificate which we can replace with the two following options:


  • A wizard-generated self-signed certificate.
  • A customer-provided self-signed certificate.

You can use the following link to deploy your own self-signed or customer provided self-signed certificate.

https://community.dynatrace.com/community/display/...

The following link is describing Custom Certificate Requirements.

https://community.dynatrace.com/community/display/...

Regards,

Babar

kbhagat
Contributor

Yes I did installed the self-signed cert to make it work but I was wondering why the certs that were working just fine in 6.2 worked with 6.5 OR why dynatrace did not ship new certs along with 6.5?

Anyway, thx. Babar for your help, my problem is solved for now.

sbhat
Guide

Should this be done mandatorily? What is the purpose of this?

kbhagat
Contributor

its kind of mandatory to get rid of low encryption warning messages in Dynatrace.

sbhat
Guide

So if I create a certificate key with my user, how will affect the other users who are accessing the same server?

Shruti,

You need to create a self-signed cert for your server. Users don't need separate keys to access Dynatrace servers. Refer below document or google on self-signed cert.

https://community.dynatrace.com/community/display/DOCDT63/Custom+Keystore+for+Dynatrace+Server+Web