cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IOS Auto Instrumentation - Very long action times

kristof_renders
Dynatrace Pro
Dynatrace Pro

Hi,

A customer has instrumented their application using the Cocoa Pods. Data is being presented back fine, however they have actions that are taking supposedly 60-70s which is certainly not the case while using the application. It is to be noted that not all actions are being reported as this long, some actions are perfectly fine.

Has anybody seen this behavior before? Wanted to check some common things I might have to check before opening a ticket.

Customer is running 6.5.

As this is a financial institution I cannot copy any data here.

Thanks in advance.

KR,
Kristof

2 REPLIES 2

david_n
Inactive

Hello Kristof,

I wouldn't assume that the actions are not taking that long to load because as you said, not all the actions are reporting the slow times. If the users are connecting via a poor data connection or have their phone memory filled with things like pictures of cats, I could see these kinds of times being a reality. Is this an internal application where users are connecting via company devices or an external app where any user can connect?

Edit - Also, are these times reported by the same user or in the same geolocation, or are they spread out?

Thanks,

David Nicholls

kin_wai_koo
Inactive

Hi Kristof,

Is the mobile app built using Cordova, by any chance? I encountered long user action times in a Cordova app a couple of months ago - it would only happen on iOS. It's supposed to be fixed in 7.0.

More details can be found in the following support case:

https://support.dynatrace.com/supportportal/browse...