cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Incident email alerting not working

thariq_rifki
Newcomer

We have configured Email Notifications for incidents, It has been working fine till now but however, I have noticed recently that we are no longer getting any email notification. I have tested the SMTP settings and can confirm that the test email works. This happens for all Incidents. We are using the email notification plugin. Can you please advise ? We are on App Mon version 6.3 @Andreas G.

11 REPLIES 11

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello Thariq,

Check the following few basic things.

  • Is there any architecture / environment change before this issue?
  • Did you check the test email with the plugin or without?
  • Can you see all the generated incidents in the Incident Dashboard?
  • Open the Server Logs and check any warning / severe messages against email.
  • Check is your plugin collector working fine or is there any Buffer, Memory or CPU Issue and also the suffice disk space available.

Please verify the above to narrow the windows for further troubleshooting.

Regards,

Babar

tthat
Inactive

@Thariq R. Is smart alerting unchecked?

thariq_rifki
Newcomer
@Taneshaa T.

Smart alerting is checked. Will that be the problem?

Hello Thariq,

As @Taneshaa T. If smart alerting is enabled then you will not receive the second alert until you do not confirm the incident from the Incident Dashboards.

Regards,

Babar

Hello @Babar Q. if smart alerting is unchecked will that mean that you will continue to receive multiple alerts for 1 incident. Just don't want to spam a mailbox.

Regard

Thariq

Hello Thariq,

Smart Alerting – If this option is selected, the defined action will be triggered just once if multiple incidents occur, until the raised incident is confirmed by a user but you can suppress the next incident for a specific time if you don't want to use Smart Alerting.

Below is an example where I suppresed the incident for the next half hour.

Regards,

Babar

tthat
Inactive

@Thariq R. yes that can be ,smart alerting reduces the alerts

@Taneshaa T. I will uncheck smart alerting and see if it makes any difference.

@Thariq R. are you receiving the alerts?

@Taneshaa T.yes receiving alerts now after unchecking smart alerting. Thanks for your help

isaac_molina
Inactive

Hello everyone,

I have the same situation, I have set up an incident for the use of disk storage and it works correctly, only at the moment of sending the notification it does it once and does not continue sending more notifications if the problem persists.


I add screenshots, hoping they can help me.

regards

IM

c4.jpg