cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Installation AppMon client 6.5 fails on MacOs Sierra

lorenz_vanthil1
Newcomer

I try to install the AppMon Client 6.5 on MacOS Sierra version 10.12.2. After downloading the .dbm I try to open it (by just double click). It Opens and show me the AppMon icon. After a double click on that icon nothing happens (or sometimes it opens in my bar and closes again).

I've installed jre-8. Uninstalled it and tried jre-7 like I read in other questions but it did not help.
The logs show me:

2017-01-23 08:58:43 [c0825c3f] info  [native] -----------------------------------------------------------------------------2017-01-23 08:58:43 [c0825c3f] info  [native]  Dynatrace Client, Copyright (C) 2004-2016, Dynatrace2017-01-23 08:58:43 [c0825c3f] info  [native] -----------------------------------------------------------------------------2017-01-23 08:58:43 [c0825c3f] info  [native] Native Launcher version: 6.5.0.1289 - built 2016.09.162017-01-23 08:58:43 [c0825c3f] severe  [native] Failed to create instance directory: /private/var/folders/y4/v8w900l115lbtzylp143pxfr0000gn/T/AppTranslocation/54797711-E8BA-4D16-AE22-9324814EB4C4/d/dynatrace client 6.5.app/Contents/MacOS/client

Someone with the same issue or with a solution? Thanks

12 REPLIES 12

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello Lorenz,

The below requirements should be considered for the Mac.


  • The Client on the Mac requires JRE 1.7 for run time.
  • Download and install the AppMon Client on Windows, Linux or MacOS X (Intel architecture only).
  • Mac: OS X 10.7+ 64bit (supported)

Try to launch the web start client.

https://community.dynatrace.com/community/display/...

Regards,

Babar

I was able to install it by dragging the dmg to the applications folder (like with many other applications). But the installer does not open the applications folder automatically so easy to forget. Thanks.

Great news.

I am not much familiar with the mac but if is there any possibility to make the shortcut on the desktop from the application.

Just a quick update. Since Dynatrace 6.5 we require Java 8 on Mac for the Dynatrace Client

vmisra
Inactive

Has anyone found solution for this ?

vmisra
Inactive

I am facing the same issue with Mac 10.12.6 and DT 6.5. Has anyone found a solution for this?

strahinja_stank
Newcomer


I had exactly the same problem (Failed to create instance directory.....) with Mac 10.13.3 & Java 9


After a downgrade -> java version "1.8.0_161", the 6.5 (took it from the location: https://files.dynatrace.com/downloads/OnPrem/dynaTrace/6.5/6.5.0.1289/index.html) will start, but frozen, and the new error is:


WARNING [Client] Unable to process command: -ws=cocoa: com.dynatrace.diagnostics.client.Client logWarning:1436


java.lang.IllegalArgumentException: Unknown command '-ws=cocoa'.

warning or not - the screens will not react at all.

Interesting is that all the time 7.1 will work, but no much benefit as the server is 6.5 😞

Hello @Strahinja S.


On Windows and Linux, the AppMon package comes with a private JRE 1.7 for run time but the Client on the Mac requires JRE 1.7 for run time.

https://community.dynatrace.com/community/display/DOCDT65/Set+up+the+AppMon+Client

The above information is particulary for the 6.5 relase.

Regards,

Babar

arturo_penen
Newcomer

I had the same problem. The screen was frozen, and the click and keyboard events didn't work

Finally, I've solved open a term

cd /Applications/dynatrace\ client\ 6.5.app/Contents/MacOS/
ls -altr

In this directory there is a symbolic link to JRE that it's too modern.

I've solved, erase it and create it linking a my old jre

rm jre
sudo ln -s /Library/Java/JavaVirtualMachines/jdk1.8.0_66.jdk/Contents/Home/jre jre

now it is:

jre -> /Library/Java/JavaVirtualMachines/jdk1.8.0_66.jdk/Contents/Home/jre

And it run

This solved my problem. Thanks!

tshain
Newcomer


Hey
@Babar Q. and @Andreas G..


My organization appears to be facing an issue similar to Strahinja.


We've begun upgrades to Mac OSX Mojave 10.14.1 and have been unable to load AppMon version 6.5.33.1011, ever since.


I've dug around in client logs and found what appears to be the same error:


+----------------------------------------------------


+ Dynatrace Client Copyright (C) 2004-2016 Dynatrace


+----------------------------------------------------


+ Version 6.5.33.1011 built Tue Jan 23 06:29:00 EST 2018


+ Platform: Mac OS X 10.14.1, x86_64 64bit


+ Running as stand-alone Client


2019-01-09 15:12:36 INFO [Client] Client Configuration Summary:


2019-01-09 15:12:36 INFO [Client] Base directory: /Applications/dynatrace client 6.5.app/Contents/MacOS/client


2019-01-09 15:12:36 INFO [Client] Config directory: /Users/taylor.shain/.Dynatrace/Dynatrace 6.5/client/conf


2019-01-09 15:12:36 INFO [Client] Cache directory: /Users/taylor.shain/.Dynatrace/Dynatrace 6.5/client/cache


2019-01-09 15:12:36 INFO [Client] Log directory: /Users/taylor.shain/.Dynatrace/Dynatrace 6.5/client/../log/client


2019-01-09 15:12:36 INFO [Client] Process: 768MB heap,


2019-01-09 15:12:36 INFO [Client] Detected CPU: logical CPU cores: 8


2019-01-09 15:12:36 INFO [Client] Available memory: 16,384 MB physical memory


2019-01-09 15:12:36 INFO [Client] Additional platform information:


2019-01-09 15:12:36 WARNING [ProxyVoleToJDKLogger] FirefoxProxySearchStrategy: Error parsing settings: java.io.FileNotFoundException: prefs.js (No such file or directory)


2019-01-09 15:12:36 INFO [ClientProxySelector] No proxy selector set because no manual configuration was set and no proxy server was detected


2019-01-09 15:12:37 INFO [Client] Could not load theme enforcing library


2019-01-09 15:12:38 INFO [Client] Registering services for support and caffeine bundles


2019-01-09 15:12:39 INFO [Client] Client base directory: /Users/taylor.shain/.Dynatrace/Dynatrace 6.5/client


2019-01-09 15:12:39 INFO [Discovery] No configs found for extension com.dynatrace.diagnostics.server.shared.browserpathtype


2019-01-09 15:12:41 WARNING [Client] Unable to process command: -ws=cocoa: com.dynatrace.diagnostics.client.Client logWarning:1436


java.lang.IllegalArgumentException: Unknown command '-ws=cocoa'.


at com.dynatrace.diagnostics.client.Client.handleCommandLineArguments(Client.java:2083)


at com.dynatrace.diagnostics.client.Client.handleInitialCommandLineArguments(Client.java:1780)


at com.dynatrace.diagnostics.client.Client.mainWindowOpened(Client.java:1522)


at com.dynatrace.diagnostics.client.core.internal.ClientWindowAdvisor.postWindowOpen(ClientWindowAdvisor.java:788)


at org.eclipse.ui.internal.WorkbenchWindow.fireWindowOpened(WorkbenchWindow.java:1363)


at org.eclipse.ui.internal.WorkbenchWindow.open(WorkbenchWindow.java:824)


at org.eclipse.ui.internal.Workbench$24.runWithException(Workbench.java:1243)


at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)


at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
(presumably, agent-based self-monitoring is not active)






My AppMon will start but then crash almost immediately with this error.


I've tried many different java versions, a few 1.7, a few 1.8, even a 1.9.


Any help you could provide would be excellent!


Thank you!


Hello Taylor,

I am afraid that support has been finished for the 6.5 version bu currently the below Mac OS are supported.


Mac: OS X 10.8/10.9/10.10/10.11 64-bit (supported). An Oracle JRE 1.8 update 121 or higher is required (no private JRE is included).

Regards,

Babar